Upload to Teensy won't work


I’m new to PlatformIO and I’m migrating my native ArduinoIDE project to PlatformIO to refactor it.

Unfortunately I’m getting this error:

Uploading .pioenvs/teensy36/firmware.hex
Teensy Loader, Command Line, Version 2.1
Read ".pioenvs/teensy36/firmware.hex": 17560 bytes, 1.7% usage
Error opening HID Manager
Soft reboot is not implemented for OSX
Waiting for Teensy device...

(hint: press the reset button)

Even if I’m pressing the reset button nothing happen. :frowning:
I’m working on Mac OSX 10.12.6 (16G29) with the latest atom App and the latest PlatformIO Packages …

Do anybody has a solution for that problem?

Hm, I’ve got a similar setup (though I’m using the CLI, not Atom) and it works just fine.

I assume that a similar build works with Teensyduino?

Have you done the obvious stuff like swap cables and USB ports?

PlatformIO uses a different command line uploader than the Mac GUI one provided with Teensyduino, but it’s been very reliable for me.


yes, with teensyduino everything works fine …
I’ve found a thread about a little “hack” but this isn’t the way I want to get it working because in my understanding I have to modify some system stuff and that can’t be the goal I think.

I didn’t tried the CLI until now, but I’m thinking about including grunt with a watcher on the built file and then executing the CLI task to upload it to my teensy … but again: this is way to complicated … there should be a better way by uploading the new firmware via the PlatformIO package … otherwise I could switch to another IDE because PlatformIO within atom is getting useless for me :frowning:

Hm, I’m not sure, something’s definitely not right. The 'Error opening HID Manager" is the useful error here.

Check out:


yeah, that’s the thread I found … I removed the teensy_loader_cli binary from the folder (like in the last post).

It’s working now … as far as I know is the softreboot currently not implemented for OSX … so I have to manually reboot the teensy … but hey … the most important thing to me was the code completion, code indention and structure :wink: :thumbsup:

Thank you for your help :beers:

The same macOS, all works well with Teensy 3.1. Is this a probem only with new Teensys? I think we can disable CLI for Teensy 3.5+

/cc @blackketter

teensy_loader_cli works fine for me with Teensy 3.6. I’m not sure what the root problem is, it predates 3.5/6, I believe.

Looking at the code, IOHIDManagerOpen() fails but I don’t know how to reproduce here to dig deeper.

@pixel-shock A shot in the dark: is your user an Administrator?

I prefer the CLI updater to the GUI one personally, happy to help fix…

@ivankravets Maybe it’s only with the new one … this is my first project with the arduino/ teensy stuff :wink:
It think the most dynamic solution would be a flag in the platformio.ini in which the user can toggle the usage of the teensy_loader_cli binary?

@blackketter Yes I’m the Admin user on that machine, I also tried it on my another MacBook and I was able to reproduce the problem with the same error message.

But since I manually rebooted the teensy after uploading via Atom+PlatfomIO it’s working with the automatic reboot with the Teensy Loader GUI open. :thumbsup: