Upload to NUCLEO-F401RE failed (no STLink found)

Hi, after following advices found here for uploading binaries via STLink dongle I’m getting the following error:

2016-04-06T18:24:34 WARN src/stlink-usb.c: Couldn't find any ST-Link/V2 devices
scons: *** [upload] Error -1

I’m currently on Windows 7 and the board is connected through USB3.0 port (sadly my laptop has no USB2.0 ports).

The STLink Utility software is able to locate the device and upload the binary, but it’s annoying to have to go through all the steps of loading the file in another app just to upload it to the board.

Is there any solution?

Hi @BrunoPires !
I’ve just tried to upload firmware using STLink tool on my Win8 + nucleo-f401re - everything works fine.
Could you try latest STLink please?

Thank you for your time @valeros, just tried the provided STLink, but still get the same error. I’ll try it in another computer, maybe on USB2.0 too.

Is there any specific firmware update version I should update my boards to? I’ve recently updated them to the latest version from ST website.

@BrunoPires Could you please try this STLink?

Thanks again @valeros, that one is a winner!

Flash page at addr: 0x08004000 erased2
016-04-07T18:13:51 INFO src/stlink-common.c: Loading device parameters....e
nabling 32-bit flash writes2
016-04-07T18:13:51 INFO src/stlink-common.c: Device connected is: F4 device (Dynamic Efficency), id 0x10006433size: 29204

2016-04-07T18:13:51 INFO src/stlink-common.c: SRAM size: 0x18000 bytes (96 KiB), Flash: 0x80000 bytes (512 KiB) in pages of 16384 bytes
2016-04-07T18:13:51 INFO src/stlink-common.c: Attempting to write 29204 (0x7214) bytes to stm32 address: 134217728 (0x8000000)
EraseFlash - Sector:0x0 Size:0x4000 EraseFlash - Sector:0x1 Size:0x4000 2016-04-07T18:13:51 INFO src/stlink-common.c: Finished erasing 2 pages of 16384 (0x4000) bytes
2016-04-07T18:13:51 INFO src/stlink-common.c: Starting Flash write for F2/F4/L4
2016-04-07T18:13:51 INFO src/stlink-common.c: Successfully loaded flash loader in sram
2016-04-07T18:13:52 INFO src/stlink-common.c: Starting verification of write complete
2016-04-07T18:13:52 INFO src/stlink-common.c: Flash written and verified! jolly good!
============================= [SUCCESS] Took 3.09 seconds =============================

Is it available in the repositories or is it a custom build?

It’s a custom STLink linked with the new libusb library with USB3.0 support.
I’ll update STLink package ASAP, but you can use this version.

1 Like


I’m getting below error with STM32F412GDISCO board :

2016-08-07T15:10:04 INFO src/stlink-common.c: Loading device parameters…
2016-08-07T15:10:04 WARN src/stlink-common.c: unknown chip id! 0x10016441

Would you please provide most recent STLink tool for win64 ?


hi valeros,
i am also facing same error while flashing code to stm32boards in ubuntu
can u please guide me

Hi guys
I have faced the same problem. It is not a platformio problem. You can go to GitHub - stlink-org/stlink: Open source STM32 MCU programming toolset and create issues in this repo.

Easy fix - Go to .pioenv/nucleo_xxx/ firmware.bin

Build (not flash) your project. This should create firmware.bin and firmware.elf files in linux and windows. Copy paste the firmware.bin file in nucleo folder (eg. /media/“username”/NUCLEO_xxx) which appears as external disc if your board supports “mbed” framework. If you are using st framework, not sure though.

This should work.