Upload Quit Working - Help

I’m using PlatformIO for vs code on a Windows 7 machine.
PlatformIO: Home V2.0.0, Core V2.6.3
VSCode: V1.30.2
Espressif 32 platform V1.6.0

The upload has been working just fine for a few weeks. Then all of a sudden it quit working. The hardware and drivers are still working just fin because I can use a terminal with the ESP32. (Both external and internal terminals) .
When I try and upload the firmware I get the following error message:
Anybody have an idea where to start looking? Thanks!

Do you have multiple COM devices on your PC? (look into the device manager to find this out).

What is your platformio.ini, especially the upload_baud setting?

There is a COM3 in the device manager that shows up. But thats always been there.

In my platformIO.ini the baud is set to 115200.

Okay so it’s auto-choosing COM5 which is correct.

Try the following on your board: Hold down the “FLASH” button and keep it pressed, then press the “RESET” button (while FLASH is still being pressed). That puts the ESP32 into bootloader mode. Can it be flashed now?

Can you also try to remove any special upload_baud setting?

Well, it turns out that was a good suggestion! Upload was successfull. I had to wait until the terminal said “connecting” to put the ESP32 into bootloader mode though.

So It seems like something in the esptool.py is not invoking the bootloader?

What exact board do you have? It should be able to do it by pulsing RTS and DTR pins of the USB-to-UART chip, which is connected to the FLASH and RESET pins of the ESP32 respectively.

I have the ESP32-DevKitC V4 from Espressif

Thanks for the help Max!! Much appreciated.

Hm… does it work without pressing FLASH and RESET now every time? This board should be perfectly OK for automatic reset before upload.

It will not upload unless I manually invoke the bootloader.
I’ll investigate more closely tomorrow. To many meetings today!

Oh, one more bit of information. I’ve tried 3 other ESP32-Devkit’s with the same result.
(changed the com port of course)