Upload_port not working for me

The path that I enter into my platformio.ini is the correct one but I get an error when I am trying to build and it will fail with the error in the second graphic. I have no clue as to what to do to resolve it.

Is that really the path to the SD card that you’re going to load the firmware onto?

Either way, you should be able to copy the firmware.bin out of the .pio/build/LPC1768 folder…

Actually that is a path to a folder on my desktop but I have also tried the path to the sd card with the same result. Not sure what I am doing wrong.

Not following the Marlin instructions, it seems. :stuck_out_tongue:


As it says in the documentation, and in the Marlin uploader script for the LPC1768, it is looking for either a file called FIRMWARE.CUR or for the volume label of the disk to be REARM … if either of those two cases are met, the script considers the drive found, and it will auto-copy the firmware to the SD card. Credit goes to Dust for outlining the existence of the custom upload script in another thread.

Hi guys,
the thread is very old but here my simple sulution.
I´ve a SKR1.4 Turbo with display attached. Everytime trying to upload the firmware.bin i got a fail message that the upload port has to be defined. After longtime search i´ve read somewhere that if the display has an SD card reader and is attached to the Board it will deactivate the onboard SD Card reader from SKR board.
So i´ve just disconnected the display and it just working.
The upload via plattform.io running without problem.