Upload File System Image

The “Upload File System Image” item seems to have gone missing from the “Run Other Target” Menu in v2.7.1 on MacOS and I don’t know how to get it back. Typing in “pio run -t uploadfs” gets tiresome quickly when testing out changes on an ESP8266. I tried making a key binding, but can’t seem to get the terminal command to execute. Keeps telling me there is no eligible target. Has anyone come up with a convenient one or two click work around for this.

Thanks much.


What version of the espressif8266 platform are you running? (pio platform show espressif8266 and it’s right at the top under the summary - for reference I was running 2.5.1, but updated to 2.5.2). I also have just looked for and seen the option missing for a project that has a file system folder but I am also running beta versions of PlatformIO and the VSCode extension.

@ivankravets @valeros Is this related to changes made to support the PlatformIO 2.0.0 VSCode extension? As I just noticed that I don’t have a ‘Upload File System Image’ option on a ESP8266 project either on the beta5 (on Linux).

Edit: Correction - I just spotted it… it’s under the environment specific ‘Platform’ tasks… which unfortunately doesn’t show under ‘Generic’ (now General) if there is only one environment in the project.

I uninstalled what I think was an older beta version of Espressif8266 and replaced it with v2.5.2. The PIO Upload File System Image menu item is still missing after restarting Atom.



Thanks for the report. This is an issue of the recent update to our extension for Atom. Please report to Issues · platformio/platformio-atom-ide · GitHub

Atom does not have explorer API and it’s difficult to implement the same UI which we did for VSCode in the recent 2.0 version.

There are a few temporary solutions here:

  1. Open Atom terminal and type directly pio run -t uploadfs or pio run -t buildfs
  2. It sounds bad from our side but highly recommend using PlatformIO IDE for VSCode for embedded development. We did primitive integration with Atom due to limited Atom’s API. It’s actually a basic editor/notepad.

See PlatformIO IDE for VSCode 2.0 Beta – Help us with testing!

1 Like

Much thanks for the advice to switch to VSCode. Better environment for ESP8266 and its file system, JS, C++, etc. Way easier for me to understand too. I found the PIO Upload File System Image selection and it soft resets the ESP, as well. So happy!


I just saw your earlier message in my email… That was a git version you were running (commit #91b3ebe and it won’t have been updating because it was in a detached state. Now that you’ve switched to VSCode, life will be a lot easier, and it will be an even better experience soon with the 2.0 extension.

The “Upload File System Image” button under PlatformIO Tasks disappeared in the latest update: CORE 5.0.1 HOME 3.3.0. I’m back to typing in run --target uploadfs in the terminal in order to upload SPIFFS files to an ESP-01. I know I should figure out how to use OTA. I tried once, but couldn’t figure out how to work around the conflict it causes with my application. Is there a way to customize the task button list so I can add this command? Thanks.

Sorry, I found the new location under my board, under Platform. I’m good now.

1 Like

Can you be more precise where you found it again? I’m really missing it to for my ESP32

Same here … thx in advance

See his crosspost: Can't find Upload FS in platformIO tasks after update to 2.0.0 (or 2.0.1) - #2 by maxgerhardt

Thank you for answering,
but unfortunately, the >platform is not present in the >env:esp32dev so cannot see the upload file system image option.
the only > available are >general, >advanced, > PIOremote
running vs on mac osx.

I don’t have that problem:

Can you post a screenshot of what your VSCode PlatformIO Tasks window looks like with the exact same platformio.ini as mine?

1 Like

Note: The Upload Filesystem menu item is under the Platform menu item which is under the env:esp01-1m menu item which is at the bottom of the Platformio left hand side menu. The env:esp01_1m menu item appears only when you have selected a script or file with the command “board = esp01_1m” in the platformio.ini file. If you have another script open, a file in it selected and the board is an Arduino MEGA w/o esp8266, the env: menu items will be different and pertain to that board only. In that case, the Upload Filesystem Image menu item will not appear.