PlatformIO Community

Upgrade Zephyr RTOS or work with older version?

Hi,

I was working with an example (samples/basic/button) from the latest Zephyr library (2.6.99) and noticed this wouldn’t compile on my PlatformIO setup (it did work with the west tool).

I went and checked and apparently there were some changes (additional structures) in drivers/gpio.h so that’s what caused the error.

So now my questions, before I go any further (don’t want to waste time, so if someone more experienced could weigh in, that would be nice :slight_smile: )

  • Is it possible to ‘update’ Zephyr RTOS manually for PlatformIO? (by replacing with a newer version in /platformio/packages/framework-zephyr) → I’m assuming not, but could someone confirm this?
  • What would you recommend: work with the newest Zephyr version (without PlatformIO) or work with the more ‘proven’ Zephyr version (with PlatformIO). → I can see both side of the argument here, but what would be ‘best’?

Have you tried it? If you just overwrite the old files (overwrite, do not delete the old content, especially not framework-zephyr/scripts/platformio/), it could work.

A cleaner way to override packages is explained in How to use latest zephy build / rc.

I’ve also opened issue Update Zephyr to 2.6.0 · Issue #541 · platformio/platform-ststm32 · GitHub so that PlatformIO will update, so this shouldn’t be a problem for too long.

Tried to overwrite didn’t work, will use the examples from 2.5.0 for now.

Subscribed to the Github issue, so I’ll know when I can update.

Thanks!