Unknown package contrib-piohome error

Trying to install PlatformIO in a computer lab environment at my school and running into this issue.

We’re running Macs with High Sierra installed, latest version of VSCode and PlatformIO.

I’ve tried to install it through VSCode and get the error that it can’t be installed, this is due to the proxy and no matter what I try I can’t get it to go through the proxy easily in such a way that students can access, it downloads fine but can’t complete the install due to the proxy.

Students, don’t have sudo rights.
I can install PlatformIO Core on all machines and have access to the pio terminal command on the student accounts.

I can then install the PlatformIO IDE extension through VSCode, however the main home screen won’t appear, throwing the error, Unknown Package contrib-piohome.

When I type pio home in the terminal I get the same error.

Note: It works fine under the administrator account and loads up in VSCode properly there.

Any idea’s how I can get around this for the students without having to go around and put the administrator password into each machine?

Found the folder I need to manually copy to each user, have tested it.

On a Mac it’s in the folder ~/.platformio/packages/contrib-piohome.

Copying this to the same directory for another user, once an install has been attempted through VSCode, created a new project and it works, took a while for the first initialisation of the tool chain but it got there in the end.

Now to deploy to all the computers… and will report back when done.