PlatformIO Community

Unittesting on a nrf52-dk

Hi,
I set up a pio project a while ago, I guess with version 5.x.
The Project uses zephyr, bluetooth, mbedtls on a nrf52-dk and the tests I wrote worked.
Now the Project was updated to pio 6 and the tests dont work anymore.
After Uploading… Testing… If you don’t see any output for the first 10 secs, please reset board… nothing more happens.
Resetting the board does not help either.

How can I debug the reason? What might be wrong?

Best Regards,
Sandra

if I follow Zephyr and Nordic nRF52-DK: debugging, unit testing, project analysis — PlatformIO latest documentation I get the same result.

Do you see any output from a board when running pio device monitor -b 115200?

I get:
could not open port ‘COM4’: could not open port ‘COM4’: PermissionError(13, ‘Zugriff verweigert’, None, 5)
Segger RTT Viewer, Ozone and all other Stuff which is maybe accessing the dk are not running, Windows 10 current patch level is freshly bootet

COM4 is the JLink CDC UART Port

Sometimes it chooses COM3 “Intel(R) Active Management Technology - SOL (COM3)”, this port can be opened, however it is the wrong port

Please pass a valid serial port to pio device monitor — PlatformIO latest documentation