Unable to use core commands. Command resulted in error, not found

So I had the platformio extension disabled in vscode, today I had some work so enabled it. The core commands like build, upload, monitor, etc were missing and error popped that commands not found. Tried reinstalling platformio, restarting laptop, but that doesn’t seem to help. Please help, I don’t wanna go back to Arduino IDE.
Didn’t install core commands.
error pop
P.s. - I have already tried uninstalling and installing platformio.

Please try a full uninstall, that is, remove the VSCode PIO extension, then remove the folder C:\Users\<user>\.platformio fully, reopen VSCode and reinstall the PIO extension. Then try creating a new project and see if it works. If your old projects do not work, do a Project Tasks -> Miscellaneous -> Rebuild IntelliSense.

Thanks for responding, but unfortunately that did not work.
Also I’m using linux mint, but I did delete .platformio and .platformio2.1 folder from my system.
And the Rebuild IntelliSense leads to this.
new error

What extensions do you have installed in VSCode?

Bracket Pair Colorizer 2, c/c++, c/c++ compile run, go, jupyter, python & theme and icon packs.

Can you deactivate all extensions but C/C++ by Microsoft and PlatformIO and retry?

1 Like

Thank you so much, that worked. Can I reinstall all my extensions?
and what may be causing this error?

My most probable guess is that your “C/C++ Compile Run” extension is causing the issue, all other extensions should be pretty safe. Install them back one by one and alsways restart VSCode after and see when things break.


Anyways after reinstalling extension everything is working just as normal. Thank you so much for your help.

Hmmm I really thought that extension would break it again. Is it that extension that gives you this right-click in file Run or compile file command? I think it then overwrites the .vscode/c_cpp_properties.json file to do that and that breaks it.

I’m not entirely sure that I get what you mean, but in the c_cpp_properties all that is working on OS default settings. Actually 4 days earlier I just reinstalled platformio extension and it worked, but today nothing seemed to work.

What exactly does the “C/C++ Compile Run” extension do? Max was suggesting that if it allows you to Run or Compile a file via a right click, it would overwrite .vscode/c_cpp_properties.json in order to function, and thus break things. I think that the errors you were getting were suggestive of the extension not installed/enabled properly since the task runner was not configured properly. I’m not sure if it prompts for you to do so, but you’d certainly need to restart (restart, not reinstall) VSCode after re-enabling the PlatformIO extension for everything to work properly.