Unable to upload build to Adafruit Trinkey - SAMD21

Hello, I’m having some trouble trying to upload code to my Adafruit NeoKey Trinkey and NeoPixel Trinkey, based on SAMD21.
After the building I tryied to upload the code via VsCode but I receive the error
SAM-BA operation failed
*** [upload] Error 1
I’ve tried any combination of connection and reset mechanism and tried both the trinkeys with different code, but nothing changed.
I didn’t track changes of updates in platformio or libraries, but for sure 2 weeks ago I succesfully upload working code in the NeoKey Trinkey. The code is the same committed to GitHub and nothing is changed but today it doesn’t upload
Any clues? Thanks

  1. Post the log of a verbose upload. That has more info. project tasks → Advanced → Verbose Upload.
  2. Try putting the device into bootloader mode by quickly double-tapping the reset button and upload again.

Hi @maxgerhardt, sorry for waste your time but I think I found the problem. When I retried today I used a different port on my mac and now the uploads are all successful.
My Mac is mounted on rack, so yesterday I was using a good manufacture usb extender and a remote connection from another machine, but apparently the trinkets doesn’t like that connection.
Today without much thinking I connected the boards to a usb hub in my desk, and now the upload works without problem. It’s the first time I encounter this type of problems and I worked with Pi Pico and various Arduino models