PlatformIO Community

Unable to resolve configuration with compilerPath

Hello, so recently i installed PlatformIO on my vscode because i am curious how it works

After i complete the installation, there is a popup on my vscode showing something like this whenever i tried to open PIO home

[1/19/2021, 08:40:43] Unable to resolve configuration with compilerPath: “C:/Users/Saiqul/.platformio/packages/toolchain-xtensa/bin/xtensa-lx106-elf-gcc.exe”

So i tried to open the folder and i found that specific file right there

image

Is there any solution to fix this ? thank you

I use PlatformIO for a while and this message started being shown for me recently too.

Apparently it’s just a warning from the VSCode C/C++ extension. It probably won’t affect PlatformIO usage.

same here:
[23/1/2021, 2:26:15 μ.μ.] Unable to resolve configuration with compilerPath "C:/Users/user/.platformio/packages/toolchain-xtensa@2.40802.200502/bin/xtensa-lx106-elf-gcc.exe". Using "C:\programming\mingw-w64\mingw64\bin\gcc.exe" instead.

Are you attempting to install PlatformIO in VSCode with a cygwin environment?

Yep, as soon as I posted that, the lightbulb blew up over my head and sure enough I was in a Linux environment. I need to be careful now that I am using VScode for Python, Django, and everything else. I clicked on the WSL in remote connections to close it, opened up my ESP8266 folder again, and all is good.

Sorry for the false alarm!!!

I’m having same issue too, although I’m in Windows 10.