PlatformIO Community

Unable to find size and start point in file eboot.elf

Aight,
So after digging through various issue trackers, I hope I am at the right place here :wink:
Long story short: I am using EspHome (A home assistant plugin to generate binaries for ESP devices). During compilation/linking an exception is thrown - which seemingly is a bug in PlattformIO.

In case the thread is the wrong subforum/subsection feel free to move it!

This is the error shown:

err

I also opened issues on the EspHome/Arduino boards, please check them out too:


The following YAML Script was used to compile an ELF binary:

esphome:
  name: smartplug1
  platform: ESP8266
  board: esp01_1m

wifi:
  ssid: censored
  password: censored
  
  manual_ip:
    static_ip: 192.168.1.195
    gateway: 192.168.1.1
    subnet: 255.255.255.0

  ap:
    ssid: censored
    password: censored

api:

logger:

ota:

web_server:
  port: 80

binary_sensor:
  - platform: gpio
    pin:
      number: GPIO0
      mode: INPUT_PULLUP
      inverted: True
    name: "Sonoff S20 Button"
  - platform: status
    name: "Sonoff S20 Status"


switch:
  - platform: gpio
    name: "Sonoff S20 Relay"
    pin: GPIO12

output:
  - platform: esp8266_pwm
    id: s20_green_led
    pin:
      number: GPIO13
      inverted: True

light:
  - platform: monochromatic
    name: "Sonoff S20 Green LED"
    output: s20_green_led

I really hope you guys can look into this problem, as it currently renders EspHome unusable for me.
Hope to get some input from you guys :slight_smile:

Execute pio settings set force_verbose Yes and restart your compilation.

What is the command that comes after Creating BIN file "...."?

What happens if you execute that command in a separate shell?

Have you checked that running /root/.platformio/packages/toolchain-xtensa@*/bin/xtensa-lx106-elf-objdump throws no error about missing shared libraries? If yes, what does ldd <path to objdump> tell you?

Also it seems fishy to me that its using packages installed as root. Are you really running everything as root? Or running as a non-root user.