Unable to detect nano every

My nano every (original, not clone) isn’t detected by my computer, making it impossible to upload a sketch. The NE powers up when connecting it (green led lights continuously, orange light flashes), but that is all.

I have tried both the arduino IDE, and platformio (6.1.13) in vs code. The latter gives a more verbose error message:

Error: Please specify `upload_port` for environment or use global `--upload-port` option. For some development platforms it can be a USB flash drive (i.e. /media/<user>/<device name>)

I looked through the instructions at https://support.arduino.cc/hc/en-us/articles/4412955149586-If-your-board-does-not-appear-on-a-port-in-Arduino-IDE#no-device-recognized, and tried two different usb cables for uploading a sketch, both of which are confirmed to work on another mcu. I also tried reinstalling FTDI drivers.

Running windows 10.

I’m not sure how to proceed from here. Your help is appreciated!

But there’s no FTDI chip on the Arduino Nano Every schematics. They use an ATSAMD11D14A as the usb-to-serial and flashing chip for the underlying ATMega4809. The SAMD11 is running the MuxTO firmware.

Fist of all, you should make absolutely sure you don’t just have missing USB drivers. Is there a Windows sound when you plug in the device? If yes, make sure to download the core, exact it, and run drivers/dpinst-amd64.exe to get the drivers for the mEDBG device.

If you really really don’t get any USB activity at all, you should try and put the SAMD11 in USB bootloader mode as described. The SWDIO and GND pins of the SAMD11 can be found on the bottom of the board as described in the pinout. You can then reflash the aforementioned MuxTO firmware to the SAMD using bossac as described.

In any case, refer to the official docs:


Thanks for clarifying regarding the FTDI drivers, as well as your detailed description.

There is no windows sound, unfortunately. And no device appearing in the windows device manager either.

Am I understanding the instructions right that, putting the SAMD11 in bootloader mode will make it appear as “MuxTo bootloader” in the IDE? Because I tried powering the NE by shorting the pins as adviced, and I can’t seem to get any indication that I succeeded. Still nothing more than the LEDs activating as described earlier.

It should yes (in the Arduino IDE). Is there no Windows conenction sound at all or an entry in the Windows device manager? Just to make sure, the procedure should be: Unplug Nano. Short D11 SWDIO with GND. Replug Nano. I’d e.g. solder a small male-to-female wire on the SWDIO pin and plug it into GND.

Yes, that’s the procedure I followed, but still no signs of life in windows or the IDE, unfortunately.

I’ll try some more attempts. Is this my last option before I consider this board a dud?

Per above linked schematics and the interactive viewer → PCB you should try and verify some points of interest with a multimeter, e.g., whether the USB port’s D+, D- lines are properly connected to the D11 chip, whether the D11 chip is receiving its proper working voltage of ~3.3V, etc.

Hmm, it appears that I don’t have a 3,3V voltage feed to the D11 chip… I’ll admit measuring becomes a bit heavy handed with the multimeter I use, but I was able to measure 3,3V further down the same trace.

Regarding USB data lines, I’m still interested in examining them, not least for learning more. What are the expected signals on an idle connection?