PlatformIO Community

Unable to detect lilygo T-QT and lilygo t display s3 board (solved)

Hello.
I work on a Linux mint system and are a member of the dialout and plugdev group (I read somewhere that that is necessary) PlatformIO is unable to detect the boards, i tried it with the boot button pressed and unpressed and with 3 different cables, googled the problem but what i found was a little bit over my head. i’m at a loss what to do next, can someone please point me in the right direction?
I recently bought a lilygo T-QT ant t display s3 , and when i wanted to up lode the demo it compiled successful, but it wouldn’t up lode to both boards. I got the following messages:

  • Executing task: platformio run --target upload

Processing ESP32-S3-DevKitC-1 (platform: espressif32; board: esp32-s3-devkitc-1; framework: arduino)

Verbose mode can be enabled via -v, --verbose option
CONFIGURATION: Redirecting...
PLATFORM: Espressif 32 (5.2.0) > Espressif ESP32-S3-DevKitC-1-N8 (8 MB QD, No PSRAM)
HARDWARE: ESP32S3 240MHz, 320KB RAM, 8MB Flash
DEBUG: Current (esp-builtin) On-board (esp-builtin) External (cmsis-dap, esp-bridge, esp-prog, iot-bus-jtag, jlink, minimodule, olimex-arm-usb-ocd, olimex-arm-usb-ocd-h, olimex-arm-usb-tiny-h, olimex-jtag-tiny, tumpa)
PACKAGES:

  • framework-arduinoespressif32 @ 2.0.3+sha.142fceb
  • tool-esptoolpy @ 1.40201.0 (4.2.1)
  • tool-mkfatfs @ 2.0.1
  • tool-mklittlefs @ 1.203.210628 (2.3)
  • tool-mkspiffs @ 2.230.0 (2.30)
  • toolchain-riscv32-esp @ 8.4.0+2021r2-patch3
  • toolchain-xtensa-esp32s3 @ 8.4.0+2021r2-patch3
    Converting lcd.ino
    LDF: Library Dependency Finder → Library Dependency Finder (LDF) — PlatformIO latest documentation
    LDF Modes: Finder ~ chain, Compatibility ~ soft
    Found 35 compatible libraries
    Scanning dependencies…
    Dependency Graph
    |-- SPI @ 2.0.0
    Building in release mode
    Compiling .pio/build/ESP32-S3-DevKitC-1/src/lcd.ino.cpp.o
    Retrieving maximum program size .pio/build/ESP32-S3-DevKitC-1/firmware.elf
    Checking size .pio/build/ESP32-S3-DevKitC-1/firmware.elf
    Advanced Memory Usage is available via “PlatformIO Home > Project Inspect”
    RAM: [ ] 4.0% (used 13232 bytes from 327680 bytes)
    Flash: [== ] 20.3% (used 266693 bytes from 1310720 bytes)
    Configuring upload protocol…
    AVAILABLE: cmsis-dap, esp-bridge, esp-builtin, esp-prog, espota, esptool, iot-bus-jtag, jlink, minimodule, olimex-arm-usb-ocd, olimex-arm-usb-ocd-h, olimex-arm-usb-tiny-h, olimex-jtag-tiny, tumpa
    CURRENT: upload_protocol = esptool
    Looking for upload port…
    Error: Please specify upload_port for environment or use global --upload-port option.
    For some development platforms it can be a USB flash drive (i.e. /media//)
    *** [upload] Explicit exit, status 1
    ============================================================================= [FAILED] Took 5.97 seconds =============================================================================
  • The terminal process “platformio ‘run’, ‘–target’, ‘upload’” terminated with exit code: 1.
  • Terminal will be reused by tasks, press any key to close it.

kint regards bert

In the CLI what does pio device list show?

pio device list,Gives nothing, a blank line

Then the computer is not recognizing the device at all.

Unplug the device. Execute sudo dmesg -w in a terminal and press enter. Plug the USB cable back in again. What new lines do appear?

I checked with 3 cables and boot button pressed and not pressed, nothing. Then checked with removing usb mouse just to see if something would happen , and it does.

Does it work on another computer?

If not, I suspect hardware failure.

Does the board seem to have power when plugged in? (Power LEDs on or something)

If you have a multimeter, measure some voltage rails / pins, like 3V3, 5V, etc.

both boards have a display, displays picture than scans Wi-Fi and displays access points and then tries to connect to a non-available access point

and with boot button pressed display a blank screen

i also begin to think that it is hardware failure, but it is strange, 2 different boards, 2 different sellers , same failure. The only thing they got in common are the cables. Thinking of buying a new cable, the others came with appliances for charging purposes, maybe they don’t have data?.

Maxgerhardt thank you for your replies, i will give an update after buying new cable.

Kind regards Bert

I can’t believe it. 2 days of thinking and genarfing. And it were the cables all along.

Thank you Maxgerhardt.

And have a nice day.

1 Like