Try to add new Board with Zephyr Support, dtsi file missing

Hey PIO Community,

I tried to follow this guide: Enabling PlatformIO and Zephyr on custom hardware | PlatformIO Labs to add a new Board with Zephyr Support to PlatformIO.

The SoC is ARM STM32F401CC (generic Blue-Black-Green Pill off ebay).
I copied stuff from the existing black Pill “WeAct BlackPill V2.0 (BlackPill F411CE)” and the “STEVAL-FCU001V1” into my project folder.

I changed the parts regarding the Chip and tried to compile, but i get a error:

zephyr/boards/arm/blackpill_f401cc/blackpill_f401cc.dts:9:10: fatal error: st/f4/stm32f401c(b-c)ux-pinctrl.dtsi: No such file or directory

When trying to compile with “board = steval_fcu001v1” it works fine. The dts file of me and the platformio dts file for steval_fcu001v1 include the same file “st/f4/stm32f401c(b-c)ux-pinctrl.dtsi”.

I never worked with zephyr before, any hints to resolve this error are greatly appreciated.

Here is my code:


Where did do you get these lines from? I can’t find this file or a file referencing this file anywhere in the Zephyr repo (Search · stm32f401c(b-c)ux-pinctrl.dtsi · GitHub) or in my local C:\Users\<user>\.platformio\packages\framework-zephyr folder

Thanks for your question. They are from the other board i copied:

I cannot find the files either. But compiling for this board “steval_fcu001v1” it is working, which i don’t get. If i comment the Line with that Import, then i get other errors.

My neither as I’m no Zephyr expert :sweat_smile:. I suggest you ask at Discussions · zephyrproject-rtos/zephyr · GitHub since it’s not PlatformIO specific where that file is or why you get that device tree error, but Zephyr specific.