PlatformIO Community

Trust Platform IO FAR BELOW ZERO

Trying to begin using PLATFORMIO

2 errors … YOU NEED ARDUINO.H => STUPID SQUIGLES are DISABLED <<<<<< LIVE WITH IT
Can not open arduino
(as ever NOT ANSWERED IN PREVIOS REQUESTS

BUILDS ONCE ok it works BUILD AGAIN FAILS MO CHANGES!!!

POINTS TO HEAVY INSTABLILITY

NO way to understand include paths FULLY CONFLICTING
even after complete reinstall

my advise KEEP AWAIY FROM PLATFORM IO AS FAR AS POSSIBLE
impossible to do anytyhing reliable

Sorry for shouting…

Since 3 weeks Have NOTHING TO SHOW FOR

You also have not engaged with the community for close to four weeks, so unfortunately this is partially self-inflicted.

Intellisense - the red code squiggles - are not part of PlatformIO, but are part of the VSCode code editor, provided via the ‘C/C++’ extension. Both of which are Microsoft products.The error you are receiving can be a result of one of several issues - changes to the C/C++ extension, bugs in the C/C++ extension, misconfiguration of the C/C++ extension via the c_cpp_properties.json file due to automatic generation or manual changes, failure to run a build to ensure all dependencies are actually installed, etc, etc.

You define custom include directories via the build_flags = -I parameter in your project configuration file, platformio.ini, as you were informed 20 days ago.

BUILDS ONCE ok it works BUILD AGAIN FAILS MO CHANGES!!!

So what is the error message you get on the second build that apparently fails with no changes? How are you expecting to resolve this without providing needed information? Please start a new topic. Outline what you have done, show the code you are using, as well as your project configuration file (platformio.ini), and give any error messages you have received. If you don’t provide this, you haven’t given enough information to help you resolve whatever issues you are facing.

1 Like

Doing a project is getting results…, not chatting arround and waiting for ages
seeing the same questions all over. NOT BEING ANSWERED.
Meaning product vallue is very low knowledge value very low…
Adding to the wast time is joining the waste
to answer: Same error as everyone else include path is VERY BAD OR NOT CONTROLABLE 9 allways erase .vcode and restart ( very unprofessional)

Never an answer ON HOW TO SET THE INCLUDE PATH.

place FILE TEST.H TEST.Cpp #include and show path or result
after command xxxxxx Libr_XXXX = c:/aaaa/bbbb/

Walking arround the problem as is NOticed else wher FOR FOUR weeks indicates
its a waste of time. to ask for the question

 2-3 days to specify OS

+2-3 days for erasing vscode

  • week for …
  • given up call closed …
    thiese 4 weeks are a waste !!!
    Never an answer ON HOW TO SET THE INCLUDE PATH.

place FILE TEST.H TEST.Cpp #include and show path or result
after command xxxxxx Libr_XXXX = c:/aaaa/bbbb/

please give a to the point answer

include path arduino.h , all other included libraries placed with or without library manager .
with or without platformio_ global libraries …
DOES NOT SEEM TO WORK

only advise vauable up to now

DO NOT USE LIBRARIES NOR INCLUDE PATH move everything local
Forget about PROJECT AND PACKEDGES … this is the only way it works
1 out of 10

 fiirst time success
 Second time  BUILD FAILURE without any change   code  
  SETUP {}   =empty 
  LOOP   {}    = empty

YOU WANT MORE INFO ???? if the BASICS OF BASICS DOES NOT WORK .....
 TRUST Platform IO FAR BELOW ZERO

Not sure if you’re still having issues with this problem @dreuzel, but here’s some references

This is such a basic thing that it is puzzling it does not work for you. Since the same empty project builds for me succesfully for multiple architectures, I would strongly suggest there must be something wrong with your setup. Other errors you’re telling about (inability to set include path, inability to use libraries) suggest the same. They work for me and many others.
Share your project somewhere so that other people are able to test.

2 Likes

@dreuzel, it’s a poor workman who blames his tools. If you are having trouble hammering a nail into a piece of wood there is no point in blaming the hammer, especially not when there are many other people happily hammering nails into pieces of wood every day using the same hammer. As Sherlock Holmes once said “once you eliminate the impossible (Platformio doesn’t work) then whatever is left (you are doing it wrong) no matter how improbable, must be the case.”
Also please note how helpful the community is trying to be, despite your angry and unreasonable outbursts. Take advantage of that. With their help, and a bit of pride swallowing on your part, they will help you sort out your problems. I can’t tell you how many problems I have had that I couldn’t solve alone, but with help from the community all of them were resolved.

Platformio is a powerful tool but there is a learning curve. You can’t expect to master it in a few days, any more than you could get into the cockpit of a Jumbo jet and expect to be able to fly it. Patience and determination are required.

8 Likes

I am new to the tool.
I m like 1000 of other users not managing to get the first step done …
after months this CAN NOT BE SOLVED … wherever I look … looking at "PLATFORMIO community " and nobody knows the first step …

What is this A BLAME EACH OTHER SESSION instead of a TOOL ???
Want a solution !!!1 NOW AFTER MONTS of WAITING

Get a simple example of 1 line and it FAILS.

What are your issues? Please provide more details.

1 Like