PlatformIO Community

Tool-openocd binary for linux_armv6l not found


#1

Hi there,

I’m trying to get things up and running for remote upload. I develop locally and want to get platformio remote upload to my raspberry pi zero w up and running. I have managed to set everything up and the local computer connects to remote agent. The RPI has openocd installed configured as a bitbanged swd dongle. A bluepill board is then connected over SWD-interface to the RPI. Openocd setup works separately.

Everything runs fine until it try to install the tool-openocd.
Error: Could not find a version that satisfies the requirement ‘~1.1000.0’ for your system ‘linux_armv6l’

Since Openocd works separately I guess there might be a way to configure it?

Any suggestions?


#2

What is your platformio.ini?


#3

Had to use 4.5.0, to get the ADC library to work in my current project.

platform = ststm32@~4.5.0
framework = arduino
board = bluepill_f103c8

#4

I see your issue. We actually have support for openOCD for ARM. You use very old dev/platform which depends on old-structure openOCD, see https://github.com/platformio/platform-ststm32/blob/v4.5.0/platform.json#L99

It seems that you can use the latest version of dev/platform but switch to mapple core? http://docs.platformio.org/en/latest/platforms/ststm32.html#switching-between-arduino-cores


#5

I have now made the following updates to platform.io

[env:stm32]
platform = ststm32
framework = arduino
board = bluepill_f103c8
board_build.core = maple

Now it compiles against the maple stm32 lib instead which is OK and the latest pio platform is used.

PackageManager: Installing tool-stm32duino @ ~1.0.1
Downloading...
Unpacking...
PackageManager: Installing framework-arduinoststm32-maple @ ~1.10000.190516
Downloading...
Unpacking...
PackageManager: Installing tool-openocd @ ~2.1000.0
Error: Could not find a version that satisfies the requirement '~2.1000.0' for your system 'linux_armv6l'

I still get the very same error, are you sure that binary exist for openocd? I saw a list where only the ARM7’s where supported (https://bintray.com/platformio/dl-packages/tool-openocd/view#files)? The device running the agent software is a Raspberry PI Zero W.

Any more suggestions?

Update…
I have managed to get it up and running by using the armv7l binary, removing the bin/openocd in tool-openocd replacing it with my custom built binary for arm6vl. But it doesnt work out of the box.


#6

Does this version https://bintray.com/platformio/dl-packages/download_file?file_path=tool-openocd-linux_armv7l-2.1000.190420.tar.gz work for you? Is this binary valid?


#7

See also