Timed out waiting for packet header

Hi all,
I’m new to platformio.
since this morning I’m going crazy to make a board work and I can’t.
I bought an AZdelivery ESP32, installed VSCode and PlatformIO on Ubuntu.

Initially I didn’t see the port, but then I enabled it
following the commands to enable usb ports for the user (on ubuntu).

I also tried to put a capacitor, as I found on the net, but nothing. PlatformIO always tells me

A fatal error occurred: Failed to connect to ESP32: Timed out waiting for packet header

do you have suggestion?
Thank you

  1. Have you installed the udev rules and rebooted?
  2. Does it help when you put the ESP32 manually into bootloader mode by holding down BOOT, pressing RESET once while keeping BOOT still pressed, then releasing BOOT?
  3. Does it help to manually configure the upload port to the /dev/ttyUSB* device that appears on plugin in dmesg -w?
  4. Does it help to lower the upload speed to 115200?

Hi, thanks for reply.
while I do the tests suggest me I will send you my .ini

platform = espressif32
board = az-delivery-devkit-v4
framework = arduino
upload_port = /dev/ttyUSB0
monitor_speed = 115200
upload_speed = 460800


I have done the suggested tests, but I find no difference.
indeed, now it tells me:

Fatal Error occured: Invalid head of packet (0x65)


And that is with upload_speed = 115200 and a removed upload_port line so that PlatformIO will figure out the serial port itself?

I solved,
I replaced the capacitor between ground and EN.
Now works!
Thank you