Throws error with the arduino STM32WB55 framework from "GrumpyOldPizza"

it didnt work with the drag and drop method but with the onboard stlink and stm32cubeprogrammer it worked and blinked like a christmass tree

That’s weird. But the STM32CubeProgrammer also flashed it at address 0x08000000?

Does it still work after doing an erase and a flash? (Idk if you need to reflash the BLE firmware though then)

i think it flashed at 0x08000000 and i think with openocd it will work without a problem

Can you try this firmware? Deleted

It’s the result of

#include <Arduino.h>

void setup() {
void loop() {
    digitalWrite(LED_BUILTIN, LOW);
    digitalWrite(LED_BUILTIN, HIGH);

with your Uart.cpp fixes.

it worked:

i found your github repo and installed it in pio myself and it is compiling

Are you sure, I just pushed the correct files 1 second ago?

It’s in

Please download the project + open in VSCode + check if compilation and upload is working.

@maxgerhardt i also relized that now and i corrected it and it made an error:

i cloned the repo you made called pio-grumpyoldpizza-stm32wb-test and opend it tried to compile and got the error

That’s weird, looks like some corrupted platform or package to me. Can you go

rm -rf ~/.platformio/platforms/ststm32*

and retry?

@maxgerhardt nope its the same no chnage

The Github actions CI can compile this just fine from a clean state: Activate CI · maxgerhardt/pio-grumpyoldpizza-stm32wb-test@76db91e · GitHub

If you don’t have custom changes in the PlatformIO packages, please do

rm -rf ~/.platformio/packages/*
rm -rf ~/.platformio/platforms/*
rm -rf ~/.platformio/.cache

and restart VSCode. It should redownload everything cleanly.

If you have time, you can also check if the BLE-UART example is working fine: Deleted

now your example compiles

ble uart works:

@maxgerhardt could you update the readme file for GitHub - maxgerhardt/ArduinoCore-stm32wb: Arduino Core for STM32WB

Well I’d only update the README file once the builder script is complete and maybe when the framework is merged into the official platform-ststm32 repo yet, but not yet. All work-in-progress right now, USB complete untested, temporary fixes still in place.

ok but write maybe in the firt line that it is a variation with pio support

Done in latest commit.

I’ve had to rename the board file to board = grumpyoldpizza_nucleo_wb55rg to be more in line with the existing board definitions. I also added all other board definitions the core supports and fixed-up the storage type and USB selection and macros so that that compiles. Untested on real hardware ofc since I have none of those boards.

You will need to update the platform code with

pio pkg update -g -p ""

on the CLI.