Terminal not working, only has flashing cursor

I’ll try and make this brief.

I’m running a 32 bit version of Xubuntu version 16.04
Atom version 18.0
PlatformIO IDE 1.2.2
Platformio-ide-terminal 2.1.0

I have my program ready to be built and uploaded but for whatever reason, I can’t open up the serial monitor or terminal within Platformio. It sits there with only a cursor and blinks. I let it sit for 30 minutes or so to make sure it doesn’t work all of a sudden.

What i am trying to do is to upload a program to an esp device but from past experiences, i need to open a serial connection, reset the device so it’s ready to be flashed, close the serial monitor, then upload.

I’ll try to open the serial monitor outside of platformio which should work… but… just wish it worked within platformio in my case.

Any hints, clues, suggestions, solutions out there? :slight_smile:

  1. Install gcc compiler. Check gcc --version
  2. Open Atom > Settings > Packages. Uninstall platformio-ide-terminal.
  3. Settings > Install > Packages and install again platformio-ide-terminal
1 Like

gcc --version gives me:

gcc (Ubuntu 5.3.1-14ubuntu2.1) 5.3.1 20160413

I tried to uninstall platformio-ide-terminal on both systems and they had the same result:
Uninstalling “platformio-ide-terminal” failed.

Failed to delete platformio-ide-terminal: Does not exist

This is odd because atom shows it as being installed.

Close Atom. Try to delete it manually using rm -rf ~/.atom/packages/platformio-ide-terminal.

P.S: I know about this problem that is linked with the Linux OS and a specific distributive. Also, I have a few ideas how to resolve it.

Do you see any errors when run these commands?

$ cd ~/.atom/packages/platformio-ide-terminal/node_modules/pty.js/
$ npm install

I have run into a similar problem. But when I try to run the port monitor, I get the message that

PlatformIO: > Terminal service is not registered.
> Make sure that "platformio-ide-terminal" package is installed.

even though the platformio-ide-terminal package is already installed. I have tried uninstalling and reinstalling a few times to no avai.

When, I tried the above suggested npm install for pty.js, I do eventually get an error:

[near the error...]

npm http 304 https://registry.npmjs.org/mkdirp/0.3.0
npm http 304 https://registry.npmjs.org/lru-cache
npm http 304 https://registry.npmjs.org/sigmund

> pty.js@0.3.0 install /home/ianfiske/.atom/packages/platformio-ide-terminal/node_modules/pty.js
> node scripts/install.js

sh: 1: node: not found
npm ERR! weird error 127
npm WARN This failure might be due to the use of legacy binary "node"
npm WARN For further explanations, please read

I am running Ubuntu 14.04 with crouton on a Chromebook. Any ideas?

  1. Install gcc
  2. Open Atom
  3. Go to Settings > Packages and uninstall platformio-ide-terminal
  4. Close Atom. Open Atom.
  5. Settings > packages > Install platformio-ide-terminal

Thank you, but I tried that and still get the same message that the Terminal service is not registered.

Do you use + icon in the status bar (bottom)? Could you click on it?

Thank you! That fixed it. The message was “this package was built for a previous version of Atom.” I pressed the ‘rebuild’ button, restarted Atom, and now it works!

1 Like