Teensy35 not found


I’m struggling with some detection issue since this morning, maybe someone here will help me?!

I am using a teensy 3.5 (MK64FX512) on MacOS (last big sure update) under VS code PlatformIO.
In dmesg I can see when I plug the teensy :

[ 432.130389]: AppleUserUSBHostHIDDevice:0x1000004a4 new user client
[ 432.130410]: IOHIDLibUserClient:0x0 [PerfPowerService] Entitlements 10 privilegedClient : Yes
[ 432.130423]: IOHIDLibUserClient:0x10000076a start
[ 432.130472]: IOHIDLibUserClient:0x10000076a setValid: from false to true
[ 432.130476]: IOHIDLibUserClient:0x10000076a setStateForQueues: 0x0
[ 432.130518]: IOHIDLibUserClient:0x10000076a open
[ 432.130525]: AppleUserUSBHostHIDDevice:0x1000004a4 open by IOHIDLibUserClient 0x10000076a (0x0)
[ 432.130534]: IOHIDLibUserClient:0x10000076a setValid: from true to true
[ 432.137028]: IOHIDLibUserClient:0x10000076a close
[ 432.137038]: AppleUserUSBHostHIDDevice:0x1000004a4 close by IOHIDLibUserClient 0x10000076a (0x0)
[ 432.137057]: IOHIDLibUserClient:0x10000076a setValid: from true to false
[ 432.137060]: IOHIDLibUserClient:0x10000076a setStateForQueues: 0x1
[ 432.137279]: IOHIDLibUserClient:0x10000076a stop
[ 432.137283]: IOHIDLibUserClient:0x10000076a setStateForQueues: 0x2
[ 432.137286]: IOHIDLibUserClient:0x10000076a close

When I try to upload (through VScode, using upload_protocol = teensy-cli or -gui) I always end to the same result: device is not found.

Here is an exemple output :

 Executing task: platformio run --verbose --target upload --environment teensy35 <
        Processing teensy35 (platform: teensy; board: teensy35; framework: arduino; upload_protocol: teensy-cli)
        CONFIGURATION: https://docs.platformio.org/page/boards/teensy/teensy35.html
        PLATFORM: Teensy (4.12.0) > Teensy 3.5
        HARDWARE: MK64FX512 120MHz, 255.99KB RAM, 512KB Flash
        DEBUG: Current (jlink) External (jlink)
         - framework-arduinoteensy 1.153.0 (1.53) 
         - tool-teensy 1.152.0 (1.52) 
         - toolchain-gccarmnoneeabi 1.50401.190816 (5.4.1)
        LDF: Library Dependency Finder -> http://bit.ly/configure-pio-ldf
        LDF Modes: Finder ~ chain, Compatibility ~ soft
        Found 89 compatible libraries
        Scanning dependencies...
        No dependencies
        Building in release mode
        arm-none-eabi-g++ -o .pio/build/teensy35/firmware.elf -T mk64fx512.ld -Wl,--gc-sections,--relax -mthumb -mcpu=cortex-m4 -Wl,--defsym=__rtc_localtime=1616432771 -fsingle-precision-constant -mfloat-abi=hard -mfpu=fpv4-sp-d16 -O2 .pio/build/teensy35/src/main.cpp.o -L/Users/pmirabel/.platformio/packages/framework-arduinoteensy/cores/teensy3 -L.pio/build/teensy35 -Wl,--start-group .pio/build/teensy35/libFrameworkArduino.a -larm_cortexM4lf_math -lm -lstdc++ -Wl,--end-group
        arm-none-eabi-objcopy -O ihex -R .eeprom .pio/build/teensy35/firmware.elf .pio/build/teensy35/firmware.hex
        MethodWrapper(["checkprogsize"], [".pio/build/teensy35/firmware.elf"])
        Advanced Memory Usage is available via "PlatformIO Home > Project Inspect"
        RAM:   [          ]   1.2% (used 3020 bytes from 262136 bytes)
        Flash: [          ]   1.6% (used 8468 bytes from 524288 bytes)
        .pio/build/teensy35/firmware.elf  :
        section                size        addr
        .text                  7228           0
        .fini                     4        7228
        .usbdescriptortable     160   536805376
        .dmabuffers             408   536805888
        .usbbuffers             864   536806296
        .data                  1240   536807160
        .bss                    348   536808400
        .ARM.attributes          48           0
        .comment                110           0
        .debug_frame            260           0
        Total                 10670
        <lambda>(["upload"], [".pio/build/teensy35/firmware.hex"])
        AVAILABLE: jlink, teensy-cli, teensy-gui
        CURRENT: upload_protocol = teensy-cli
        teensy_reboot -s
        teensy_loader_cli -mmcu=mk64fx512 -w -s -v .pio/build/teensy35/firmware.hex
        Teensy Loader, Command Line, Version 2.1
        Read ".pio/build/teensy35/firmware.hex": 8472 bytes, 1.6% usage
        Soft reboot is not implemented for OSX
        Waiting for Teensy device...
         (hint: press the reset button)

Can someone please point me how to debug my issue ? I am pretty confused.

Have you tried the advice in Troubleshooting common problems with the Teensy USB development board regarding " Teensy Not Recognized by Teensy Loader"?

Thank you for your answer. I did everyhting mentionned except try another USB-C to USB-B adapter (i am using a 2019 macbook which only expose 2 USB-C ports).
I am going to try on an older machine and let you know.

Just tried another USB-C => USB-B adapter and both CLI / GUI (through pio and teensyduino) didn’t succeed…
Are there some more steps to perform before buying a new teensy?
thank you very much!

Can you also make double sure that this is not a problem related to PlatformIO by installing TeensyDuino for the Arduino IDE normally and attempting an upload?

Maybe the Teensy people know more here after that. I’d say try at https://forum.pjrc.com/.