T-Display-S3 (esp32s3) on boot says cpu_start: Octal Flash option selected, but EFUSE not configured!

I’m hoping someone can help me get this board going. I can’t get the board to boot. When programmed in Arduino it boots fine. But with PIO it spits out the EFUSE error as following

entry 0x403b61d8
E (200) cpu_start: Octal Flash option selected, but EFUSE not configured!
Build:Mar 27 2021
rst:0xc (RTC_SW_CPU_RST),boot:0x8 (SPI_FAST_FLASH_BOOT)
Saved PC:0x40376d98
mode:DIO, clock div:1

below is my platformio.ini

platform = https://github.com/platformio/platform-espressif32.git
platform_packages = framework-arduinoespressif32@https://github.com/espressif/arduino-esp32.git#2.0.3
board = esp32-s3-devkitc-1
upload_speed = 115200
framework = arduino

board_build.partitions = huge_app.csv

board_build.arduino.memory_type = opi_qspi

build_flags =

-D ESP32




Nevermind. it was this line :
board_build.arduino.memory_type = opi_qspi

I commented it out and it started working. duh.

Hey tavdog

I know it has been a long time, but I’ve been trying to load up a demo firmware on esp32-s3-zero (FH4R2) - (4 mb flash and 2 mb psram). My code uploads to the system, but as soon as I start serial communication, I get the same error.

My platformio.ini looks like this:

platform = espressif32
board = esp32s3camlcd
framework = arduino

platform_packages = 

board_build.mcu = esp32s3
board_build.flash_mode = dio

build_unflags = -std=gnu++11

build_flags = 

lib_deps = 

upload_speed = 115200
monitor_speed = 115200

The board that I got is this: 6.88€ 5% OFF|ESP32 S3 Mini Entwicklungs platine ESP32 S3FH4R2 Dual Core Prozessor 240MHz 2,4 GHz Wi Fi| | - AliExpress

I tried many things, but this error won’t go away. If you have any insights or suggestions, I’d be grateful. Many thanks! :slight_smile: