Suddenly don't have permission for debugging

I have a PIO Plus Professional for Business account. Since last week, whenever I try to debug, the process aborts with a dialog stating “The preLaunchTask ‘undefined’ terminated with exit code 1”.

The terminal shows this:
> Executing task in folder RainGen2_100b: C:\Users\jjuni.platformio\penv\Scripts\platformio.exe debug <

PIO Plus ( v2.2.1
Error: You do not have permission for this operation. Please use pio account show command to check current permissions.
Further details: or
The terminal process terminated with exit code: 1

I have tried logging out and re-logging in without success.

This leaves me dead in the water. HELP!

Further info: When I use the terminal pio account show I get:

PS C:\Users\jjuni\Documents\PlatformIO\Projects\RainGen2_100b> pio account show
PIO Plus ( v2.2.1

Logged as:
PIO Plus Plan: PIO Plus Professional for Business

Group PIO Plus Community

Expire: -
Permissions: OTA Device Manager, Remote Agent List, 100 Shares per Remote Agent, 100 Concurrent Remote Agents, Remote Serial Port Monitor (50,000 per month), Remote Firmware Updates (100,000 per month), Remote Unit Testing (100,000 per month)

Group PIO Plus Professional for Business

Expire: 2020-06-10 20:00:00
Permissions: Unlimited Remote Serial Port Monitor, Unlimited Remote Firmware Updates, Unlimited Remote Unit Testing, Unlimited Remote Agents, Unlimited Remote Agent Shares, Premium Support (Developer) → A professional collaborative platform for embedded development · PlatformIO

Here is my launch.json:

“version”: “0.2.0”,
“configurations”: [
“type”: “platformio-debug”,
“request”: “launch”,
“name”: “PIO Debug”,
“executable”: “c:/Users/jjuni/Documents/PlatformIO/Projects/RainGen2_100b/.pioenvs/adafruit_feather_m4/firmware.elf”,
“toolchainBinDir”: “C:/Users/jjuni/.platformio/packages/toolchain-gccarmnoneeabi/bin”,
“svdPath”: “C:/Users/jjuni/.platformio/platforms/atmelsam/misc/svd/ATSAMD51J19A.svd”,
“preLaunchTask”: {
“type”: “PlatformIO”,
“task”: “Pre-Debug”
“internalConsoleOptions”: “openOnSessionStart”
“type”: “platformio-debug”,
“request”: “launch”,
“name”: “PIO Debug (skip Pre-Debug)”,
“executable”: “c:/Users/jjuni/Documents/PlatformIO/Projects/RainGen2_100b/.pioenvs/adafruit_feather_m4/firmware.elf”,
“toolchainBinDir”: “C:/Users/jjuni/.platformio/packages/toolchain-gccarmnoneeabi/bin”,
“svdPath”: “C:/Users/jjuni/.platformio/platforms/atmelsam/misc/svd/ATSAMD51J19A.svd”,
“internalConsoleOptions”: “openOnSessionStart”

Don’t know if this is relevant but my PlatformIO briefly popped up with a “you do not have a platformIO account” message and would not compile, I restarted my machine and it went away.

Thanks for the suggestion, Foxa.
I have rebooted the computer and restarted VSCode IDE, but neither worked. Still get the same error: “The preLaunchTask ‘undefined’ terminated with exit code 1.”

Additional info:
When I click “Show Errors” on the dialog, the Terminal says “No problems have been detected in the workplace so far.”
When I click “Debug anyway”, the dialog disappears, but nothing seems to happen.

yea, this is odd, if you look in your terminal window is there anything about libusb() failed with LIBUSB_ERROR_NOT_SUPPORTED ? as that has just started to happen to me
[Edit forget that, I think mine was down to bad usb drivers]

Thanks for the suggestion, but nothing about libusb appears. The only text in the terminal window is that shown above.

Could you open PlatformIO IDE Terminal and type pio update? You need PIO Plus 2.5.2 or above. Please note the PlatformIO Core 4.0 already contains open sourced PIO Unified Debugger. The final release is planned for this week.


I did pio update, but still have same problem.
The error message on the terminal seems to indicate that I have PIO Plus v2.2.1
How do I get to the latest version of PIO Plus?

What do you get when you run run pio update -c --core-packages ? Does it show something like?

Checking tool-scons                      @ 2.20501.7      [Up-to-date]
Checking tool-unity                      @ 1.20403.0      [Up-to-date]
Checking contrib-pysite                  @ 2.27.190418    [Up-to-date]
Checking contrib-piohome                 @ 2.2.0          [Up-to-date]
Checking tool-pioplus                    @ 2.5.2          [Up-to-date]

If it says tool-pioplus has an update, you can run the same command minus the -c to actually update. Otherwise, and I’d wait for Ivan to comment before actually doing this unless you’re happy to remove the PlatformIO folder and let it re-install if things go wrong, maybe you need to run pio upgrade --dev to get the later pioplus until the v4 drops?

1 Like

I only used pio update without any options. Had out similar (as I recall) to your example above. Still no success.

Then deleted entire ~/.platformio/packages directory and tried pio update again. This time, I had errors with antivirus software and the connection.

Changed VSCode settings to use Development version of PIO. Rebooted. Process went partway, then stalled with connection error.

Got IT to WhileList “” for the McAffee anti-virus package. Restarted computer, the VSCode. Did pio update. All now seems to be working again!

Hopefully, having the mother ship Whitelisted will help avoid further problems when changes are made to the platform (which I assume was the problem here)

Thanks to all for your help in tracking down this very frustrating problem!