PlatformIO Community

Ststm32: dfuutil @1.11.0 missing for linux_aarch64

Hi all

Since one of the recent upgrades accompanying platformio core v6.0, when trying to deploy to stm32 from a raspberry pi, we are getting the following error:

Tool Manager: Installing platformio/tool-dfuutil @ ~1.11.0
Error: Could not find the package with 'platformio/tool-dfuutil @ ~1.11.0' requirements for your system 'linux_aarch64'

I found this similar thread which references an older version.
Followed the very detailed instructions to build dfu-util myself on the pi, tested that it worked locally, and I am now ready to share the built and packaged version.

What is the best course of action to share the package and get it incorporated in platformio registry?

1 Like

I think STSTM32 - Could not find the package with 'platformio/tool-dfuutil @ ~1.9.190708' requirements for your system 'linux_aarch64' - #8 by maxgerhardt still holds up, open a new issue with the original error message in platform-ststm32 and attach the tar.gz package file.

Great thanks btw on compiling that and helping out!

1 Like

Please add any package.json with “name” and “version” fields to the root of built packages and run pio pkg pack. Next, please share tar.gz via Dropbox, GoogleDrive, etc., and paste a link here.

Perfect, here it is: Nextcloud

Thanks, done! :rocket:

1 Like