PlatformIO Community

Strange Linker Error when trying to build with esp-adf components

Hi Everyone,

I was trying to use esp-adf components following the instructions in the PIO Docs. Now, when building the project, I’m running into the following linker error:

/Users/myName/.platformio/packages/toolchain-xtensa32@2.80200.200827/bin/../lib/gcc/xtensa-esp32-elf/8.2.0/../../../../xtensa-esp32-elf/bin/ld: group ended before it began (--help for usage)
collect2: error: ld returned 1 exit status
*** [.pio/build/esp32dev/firmware.elf] Error 1

I ran a verbose build to output the ld command line in the hope to find some hint on which file causes the problem, but tbh I have no idea how to interpret either the error message nor the collect2 output. I made sure to use platform=espressif32@2.0.0 in the platform.ini for the ADF only runs with ESP-IDFv4.1. I created a GitHub Repo if someone’s keen to have a look. The commit should include the log-file of the verbose build. The main.c contains a very simple program only to test if I can successfully include one of the libs and call one of its functions. I’m aware that it won’t run correctly, but I think it should build.

Saluti e grazie
Dennis

Hi, denmuellner, I’m getting the same error. Did you solve the issue?
Looks like the ADF and skainet is bound to a very specific IDF and toolchain version.
I’m still tinkering it

try this:

build_unflags = -Wl,--end-group

Hi @krembuk,
your fix worked for me, too so thanks a lot for sharing! And so simple it’s too good to be true. I guess sometimes you’re so deep in the maze you can’t see over over the wall.

Cheers!