Stop updates happening without asking


#1

I’d like to be able to stop PlatformIO Core from updating things unless I explicitly ask. I think it’s bad practice to just have dependencies update for no reason other than that there is a newer version out. Is it possible to stop PlatformIO from doing this?

I found this old thread but the question in the title wasn’t actually answered: Disable auto update? (or auto update state issue?)


#2

The issue I originally had was different, and related to multipl PlatformIO installs. I agree with your sentiment though. Does this not work for you? http://docs.platformio.org/en/latest/userguide/cmd_settings.html#settings

I haven’t tried it yet.


#3

Thanks for the response, I didn’t know about that setting actually. But it doesn’t seem to work as it should already be set to “No”. Platformio actually updated some package right when I checked it :laughing:

 $ pio settings get
Name                            Value [Default]   Description
------------------------------------------------------------------------------------
auto_update_libraries           No                Automatically update libraries (Ye
auto_update_platforms           No                Automatically update platforms (Ye
check_libraries_interval        7                 Check for the library updates inte
check_platformio_interval       3                 Check for the new PlatformIO inter
check_platforms_interval        7                 Check for the platform updates int
enable_cache                    Yes               Enable caching for API requests an
enable_ssl                      No                Enable SSL for PlatformIO Services
enable_telemetry                Yes               Telemetry service <http://docs.pla
force_verbose                   No                Force verbose output when processi
projects_dir                    /home/kaspar/Documents/PlatformIO/Projects  Default 
Updating contrib-piohome                 @ 0.9.3          [0.9.4]
Uninstalling contrib-piohome @ 0.9.3: 	[OK]
CorePackageManager: Installing contrib-piohome @ 0.9.4
Downloading  [####################################]  100%          
Unpacking  [####################################]  100%
contrib-piohome @ 0.9.4 has been successfully installed!

************************************************************************************
There is a new version 3.5.3a8 of PlatformIO available.
Please upgrade it via `platformio upgrade` or `pip install -U platformio` command.

#4

Haha. I expected as much. I had the same thing. I asked platformio to list the settings, and it decided I really needed some fresh new libraries. It’s broken behaviour. But I don’t know what’s going on, or have the time to look into it.

Are you sure you’re not experiencing the same issue as I had, multiple installations? I’m asking because this issue is about disabling auto-update, suggesting your installation would be auto-updated, and if that would include pio itself, you should not see the “There is a new version” message. Which is the same issue I had, multiple installs.

PS: Pio is Open Source and mostly Python, which is really easy to read. It might be worth the dig into the source code to check where these settings come from/are stored.


#5

I just found out about locking down dependencies for a particular project which is what I really cared about.


#6

You can lock all dependencies in PlatformIO, including, libraries and platforms. See