Stop platformio core from updating


Since I have an issue with platform io core 4.1.0 compiling firmware where the screen doesnt work(even with newest marlin) I want to rollback to 4.0.3. I do the rollback but as soon as I start vscode it starts installing the new version again.

Any idea how I can stopt this so I can stay on 4.0.3

I suspect that it’s more a problem that VSCode PlatformIO extension appears to require version >=4.1.0 of the PIO Core (understandable as it references features added in that version)… so when you restart VSCode and the extension checks what version is installed on startup, it updates. So you’ll need to revert to v1.9.3 of the PlatformIO Extension in VSCode, and disable extension auto-updates, else VSCode will auto-update the extension, and set the whole merry go round off again.

To disable extension auto updates:

To install a specific version of an extension, follow this and then pick your version:

PlatformIO does have an update checker, but I don’t think it updates the Platform IO core, but instead checks for updates to platforms and libraries. You can see the settings for that, and other stuff, by entering pio settings get at a terminal prompt where PlatformIO works.

Works thank you very much

1 Like

Could you provide more details? I did a PR a few weeks ago to Marlin and the latest code from their repo should work.

1 Like