Stm32duino platform not uploading anymore

Hi when uploading my sketch to my STM32 device I’m getting the following error

If I look in the tools directory the serial_upload script is present there. I have deleted everything and installed again but still the problem persists. I’m using atom on W10 x64. latest versions of, Stm32duino framework and tools.

If useful, uploading the same sketch with arduino IDE works as expected.

Can someone help me please to understand what’s wrong?

Thank you


I also get the same error.
Found some old suggestions that say to add:

upload_protocol = dfu

And now I get: ‘‘maple_upload’’ is not recognized as an internal or external command,
operable program or batch file.


Same problem here, can’t upload on mapleMini anymore.

I made a git issue yesterday about this, i did various hard reset of PIO/STSTM32 but nothing so far…

I get the same error as @insidecircuits.

Please try this solution Maple Mini Upload Problem · Issue #77 · platformio/platform-ststm32 · GitHub

The upload problem has indeed been resolved in the latest Platformio Core release 3.5.1a1.
I must still mention that on my laptop the update came automatically while on my PC I could not get it to check for updates and get the new version, even checking development versions options in the Platformio - Settings menu.
I had to force "pio upgrade --dev" to make it update it.

One problem remains, I have to manually push the reset button after I click upload because it gets stuck at this step:

After the upload I have to press the reset button again to make it exit the bootloader and start running the new firmware.

I do not know how it was before because I have not tried it but maybe someone else can tell.

Also, if I don’t press the reset it will wait some time for the board and search the device.

The programming does not work but insteadd of an error it throws: [SUCCESS] which is also annoying because you cannot rely on it to know if the programming was successful or not.
Couldn't find the DFU device: should be an error not a warning.

It looks like for me it was also a bootloader problem. I had to flash it again. Now uploading works.
Only thing remains that I have to reset the board manually for it to enter bootloader mode, most of the time.