Stm32cube and bluepill_f103c8 no linker script (no boot)

I get this error:

Warning! Cannot find a linker script for the required board! Firmware will be linked with a default linker script!

Is the linker script required, for it to run, is the stm32cube support for this board perhaps incomplete or is there a way to adapt it?

My platformio.ini:

platform = ststm32
framework = stm32cube
board = bluepill_f103c8
build_flags = -DF1

I’m trying to get the led blink example from here to run, I can compile it, upload it but it doesn’t run.

The equivalent mbed example works fine, the project I’m doing requires control for 16x fast pwm in a tightly coupled manner, so I doubt mbed will do.
According to pinout diagrams the LED on the bluepill boards is either on B13 or C13
So I tried setting the LED pin to

#define LED_PIN                                GPIO_PIN_13
#define LED_GPIO_PORT                          GPIOC

I also tried various other pins & ports and see if I get an output.

I’ve gotten rid of the message by consulting,

using the solution from @ivankravets and downloading


but still no luck

Please file an issue here Issues · platformio/platform-ststm32 · GitHub

I know it’s a late answer, but I just bought the BluePill and this is my first try.
Today I stumbled across the same error, trying to run the stm32cube HAL blink example.
I checked the differences in linker scripts for F103C8 and F103CB boards, and both of them against script generated by the STM32CubeMX.

There is an error in default linker script for the STM32F103C8 chip.
In the STM32F103C8_DEFAULT.ld file the line for stack has a missing “0”

_estack = 0x2005000; /* end of RAM */

and the correct value is

_estack = 0x20005000; /* end of RAM */

After change and recompilation, the BluePill started to blink.
Then I made a custom STM32F103C8_FLASH.ld script using the CB version as a template, because the only difference is the flash size:

FLASH (rx) : ORIGIN = 0x8000000, LENGTH = 64K

Now the linker is working without errors.