STM32 USB upload error

Im newbie, im wrote some led blink code and want to upload to my blue pill (STM32F103C8)
i recv this error:

Configuring upload protocol...
AVAILABLE: blackmagic, cmsis-dap, dfu, jlink, serial, stlink
CURRENT: upload_protocol = dfu
Looking for upload port...
Using manually specified: COM1
Uploading .pio\build\genericSTM32F103C8\firmware.bin
maple_loader v0.1
Resetting to bootloader via DTR pulse
# A fatal error has been detected by the Java Runtime Environment:
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x000000007110b5db, pid=10436, tid=6068
# JRE version: OpenJDK Runtime Environment Temurin-11.0.18+10 (11.0.18+10) (build 11.0.18+10)
# Java VM: OpenJDK 64-Bit Server VM Temurin-11.0.18+10 (11.0.18+10, mixed mode, tiered, compressed oops, g1 gc, windows-amd64)
# Problematic frame:
# C  [jSSC-2.8_x86_64.dll+0xb5db]
# No core dump will be written. Minidumps are not enabled by default on client versions of Windows
# An error report file with more information is saved as:
# C:\Users\Chipuku\.platformio\packages\tool-stm32duino\hs_err_pid10436.log
# If you would like to submit a bug report, please visit:
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.

How can i fix this, i try to remove oracle java path in enviroment var. still no work

1 Like

same here, but in another computer it works.
maybe solved:

  1. download from Releases · java-native/jssc · GitHub the source.
  2. rename jssc.dll to jSSC-2.8_x86_64.dll
  3. copy c:\users\username.jssc\jSSC-2.8_x86_64.dll