STM32 upload Error "failed to init device." w/ Bluepill on OSX Big Sur over Serial

When I try to upload any code, I get this error:

Scanning dependencies...
No dependencies
Building in release mode
Checking size .pio/build/bluepill_f103c8_128k/firmware.elf
Advanced Memory Usage is available via "PlatformIO Home > Project Inspect"
RAM:   [          ]   3.8% (used 780 bytes from 20480 bytes)
Flash: [=         ]   7.3% (used 9604 bytes from 131072 bytes)
Configuring upload protocol...
AVAILABLE: blackmagic, cmsis-dap, dfu, jlink, serial, stlink
CURRENT: upload_protocol = serial
Looking for upload port...
Using manually specified: /dev/cu.wchusbserial14130
Uploading .pio/build/bluepill_f103c8_128k/firmware.bin
Failed to init device.
stm32flash Arduino_STM32_0.9

Using Parser : Raw BINARY
Interface serial_posix: 115200 8E1

*** [upload] Error 1

this is my platformio.ini-file:

platform = ststm32
board = bluepill_f103c8_128k
framework = arduino
upload_port = /dev/cu.wchusbserial14130
monitor_port = /dev/cu.wchusbserial14130
monitor_speed = 115200
upload_protocol = serial

I already tried:

  • several bluepill-boards
  • different Serial-USB-adapter
  • put the board into serial-mode (Boot0=1, Boot1=0)

I run VScode on OSX Big sur (patched sur tbh). What could be the problem? Did I miss something?
Thank you in advice :slight_smile: