PlatformIO Community

Start debugging immediately goes to configure task

I’m trying to start the JTAG debugger. I’ve had this working in the past but haven’t used for 9 mionths or so.

I’ve checked wiring connects for accuracy and continuity. Also added debug_port=localhost:3333 to the pio.ini file.

The issue is that when I Run > Start Debugging the Command Palette comes up and asks “Select a task to configure”. When I select the blink task the tasks.json file is displayed. Once I get to this point I don’t know what to do.

I have platformio.ini, adapter speed = 10000 and ftid set to 403 6010 (from Zadig).

I can start the blink program and it blinks the led. When I want to debug I get the confiure task message.

Has there been updates to PIO that I should be concerned about

This should not occur. Make sure to select the environment and project you want to debug through the project environment switcher. Reloading tasks takes a second. After that, Run → Start Debugging should start up with a compilation and then output in the “debug console”. If that is not happening and you get the same error, restart VSCode, delete the .vscode folder of the project and to a Ctrl+Shift+P → Rebuild IntelliSense to regenerate the .vscode folder. If debugging still doesn’t start up, you might have conflicting extensions installed. Remove / deactivate all but C++ by Microsoft, Python and PlatformIO to check this.

I deleted the .vscode folder and then rebuild and the problem was resolved. Thanks.