Hi, I got this error message when trying to download PlatformIO IDE Extension on VS Code. I am using Windows. Anyone is also experiencing the same issue or has solved this?

I tried downloading PlatformIO IDE on 2 different computers and 1 can be downloaded with no issues but the other one has this error message.

Any help is appreciated Thank you!

Check if you have a folder C:\Users\<username>\.platformio

If the folder exists:

  • close VS Code
  • delete the folder (or rename it to keep its content)
  • start VS Code
  • wait until PlatformIO has performed all tasks (reinstallaton)

i tried this when my platformio ide is taking forever to initialise and it works, but the error i am getting is after i have downloaded the python 3.12.4, so does this solution work for the error i am facing?

I have not installed Python manually and use the Python automatically installed by PlatformIO.
I can’t guarantee that this solution will work, but you can give it a try.

did you have this error while initialising platformio to start? as python wasn’t automatically installed by platformio for me. i had to click on the option shown in the picture to download it.

No, I didn’t have this (or I can’t remember it).
Did you also have this on the other (working) computer?

yes for all the computers i tried it all shows this prompt to download python

I remember this bug. It was a few years ago. At that time I had installed a Python version. Removing Python and reinstalling PlatformIO had helped.

will try to uninstall python and platformio and try again thank you!