Source `partitions.csv' not found Very limited information on this issue

Hi all,

I have installed the PLATFORM IO extension on VScode with the aim to program an ESP 32 S3 2MB PSRAM (Adafruit). I did this after a build issue was happening using the Arduino IDE plug in and the ESP example files would compile, upload and run fine, but none of mine would v(they would compile, run and upload fine according to the verbose) the board would not do anything. I looked at information around and bugs like this were common, so I wanted to use a more robust system.

To test, I have just tried to build a simple project, all works fine till this error comes up, in the termina, this is in verbose mode:

Processing adafruit_feather_esp32s3 (platform: espressif32; board: adafruit_feather_esp32s3; framework: arduino; monitor_speed: 115200; lib_deps: adafruit/Adafruit Motor Shield V2 Library @ ^1.1.1)
PLATFORM: Espressif 32 (5.3.0) > Adafruit Feather ESP32-S3 2MB PSRAM
HARDWARE: ESP32S3 240MHz, 320KB RAM, 4MB Flash
DEBUG: Current (cmsis-dap) External (cmsis-dap, esp-bridge, esp-builtin, esp-prog, iot-bus-jtag, jlink, minimodule, olimex-arm-usb-ocd, olimex-arm-usb-ocd-h, olimex-arm-usb-tiny-h, olimex-jtag-tiny, tumpa)
 - framework-arduinoespressif32 @ 3.20006.221224 (2.0.6)
 - tool-esptoolpy @ 1.40400.0 (4.4.0)
 - toolchain-riscv32-esp @ 8.4.0+2021r2-patch5
 - toolchain-xtensa-esp32s3 @ 8.4.0+2021r2-patch5
LDF: Library Dependency Finder ->
LDF Modes: Finder ~ chain, Compatibility ~ soft
Found 42 compatible libraries
Scanning dependencies...
Dependency Graph
|-- Adafruit Motor Shield V2 Library @ 1.1.1 (License: Unknown, Path: C:\Users\scareface\wifitest\.pio\libdeps\adafruit_feather_esp32s3\Adafruit Motor Shield V2 Library)
|   |-- Adafruit BusIO @ 1.14.1 (License: Unknown, Path: C:\Users\scareface\wifitest\.pio\libdeps\adafruit_feather_esp32s3\Adafruit BusIO)
|   |   |-- Wire @ 2.0.0 (License: Unknown, Path: C:\Users\scareface\.platformio\packages\framework-arduinoespressif32\libraries\Wire)
|   |-- Wire @ 2.0.0 (License: Unknown, Path: C:\Users\scareface\.platformio\packages\framework-arduinoespressif32\libraries\Wire)
Building in release mode
*** [.pio\build\adafruit_feather_esp32s3\partitions.bin] Source `partitions.csv' not found, needed by target `.pio\build\adafruit_feather_esp32s3\partitions.bin'.

I have tried to follow this this from a commit a few years ago. I just don’t think I understand the issue enough to tackle it at the root. I know the importance of the partition table but in that case why is such a crucial thing missing.

Here is my platform.ini file :

; PlatformIO Project Configuration File
;   Build options: build flags, source filter
;   Upload options: custom upload port, speed and extra flags
;   Library options: dependencies, extra library storages
;   Advanced options: extra scripting
; Please visit documentation for the other options and examples

platform = espressif32
board = adafruit_feather_esp32s3
framework = arduino
monitor_speed = 115200
lib_deps = adafruit/Adafruit Motor Shield V2 Library @ ^1.1.1

As simple as it can be.

Please HELP and let me know what I am missing, but my gut feel is that a default partition table should not be missing.

There was a fix for this at Update default partition tables for Adafruit Feather S3 based boards · platformio/platform-espressif32@6660f2c · GitHub and a platform update. Just open a CLI and execute

pio pkg update -g -p espressif32

to get the 6.0.0 version.

1 Like

Thanks so much @maxgerhardt I was not aware of this, coming from the Arduino IDE, I have yet alot to learn. Cheers!