[Solved] Trinket 5V 8MHz - timing issues

Hello. I am using a Trinket 5V 8MHz controller with PlatormIO. The timing seems to be off. Is there a way for me to reconfigure it to run at 8MHz? There was not an option to select the 8MHz version when I created the project.

You need Redirecting...

Added board_f_cpu = 8000000L, did not seem to alter the board timing behavior.

What is your platformio.ini?

Here is what I have in my platformio.ini at the moment. I am running on MacOS X 10.12.1. The Arudino IDE seems to work fine with the download. I just added the board_f_flash = 8000000L and that did not seem to have any affect on the timing.

Thank you for the help.

platform = atmelavr
board = trinket5
framework = arduino
upload_protocol = usbtiny
board_f_cpu = 8000000L
board_f_flash = 8000000L

Please fill issue here Issues · platformio/platform-atmelavr · GitHub

Also, please provide full build output from Arduino IDE. You can enable verbose mode in Arduino IDE settings.

Ok, issue entered. Thanks.

Ivan, I updated PlatformIO per your request and downloaded the code to the Trinket. The timing and seems to be the same as the code that was downloaded from the Arduino IDE.

I think the anomaly that I observed previously has been addressed by the recent updates. Thank you.

What was changed?

We updated Arduino Core to the latest stable version. Please close this issue if you don’t have any problems.

Update resolved issue. Issue closed.