[Solved] Code won't work properly when using PlatformIO for Arduino

Hi guys. Im new here and im testing my WS2811 led matrix arduino code with PlatformIO. Im able to upload and build the code but it just doesn’t seem to work. I still get the messages from serial as should, but the leds just wont turn on. I have made code using FastLED libraries and it’s working just fine when using Arduino IDE. Anyway if i try to make just some simple led blink code (not using FastLED) using PlatformIO, it seems to work just as expected. I tested also some FastLED example projects and they doesn’t seem to work if built and uploaded them with PlatformIO, but they works if i use the Arduino IDE. Im out of ideas what could be causing this issue.

Any ideas could be nice, as looks like the PlatformIO woul be a really good IDE for Arduino otherwise.

What is your platformio.ini?

Looks like this:


platform = atmelavr
board = megaatmega2560
framework = arduino

Please file an issue here Issues · platformio/platform-atmelavr · GitHub

Thanks for your response.
Issue: FastLED libraries does not behave as expected (Arduino Mega 2560) · Issue #31 · platformio/platform-atmelavr · GitHub

Okay, the led chain is now workin with PlatformIO.
I updated FastLED libraries from 3.0.0 to 3.1.4.