[SOLVED] Avrdude_bin not found in packages/tool-avrdude

avrdude_bin from the platformio package is just not compatible with my arm64 orangepi.
I just raplaced the avrdude_bin with /usr/bin/avrdude.
That’s the solution for me.


I am setting up my OrangePi PC2 as remote Agent to flash my ATMega2560. If I flash manually with /usr/bin/avrdude everything is working fine.

if i run “pio run -t upload” on my orangepi I get following message:

avrdude -v -p atmega2560 -C /home/pi/.platformio/packages/tool-avrdude/avrdude.conf -c wiring -b 115200 -D -P “/dev/ttyUSB0” -U flash:w:.pioenvs/megaatmega2560/firmware.hex:i

/home/pi/.platformio/packages/tool-avrdude/avrdude: line 6:
/home/pi/.platformio/packages/tool-avrdude/avrdude_bin: No such file or directory
*** [upload] Error 127

I can see the file avrdude_bin but I cant run it (with chmod +x) .

As I said the command works manually with /usr/bin/avrdude but not with ~/.platformio/packages/tool-avrdude/avrdude
(I tried to use /usr/bin/avrdude for platformio but this is just causing new problems… It just stucks after the avrdude command)

Can someone tell me what I am missing?