Serial ports not found

PIO home “devices” isn’t showing any serial ports, yet I have devices plugged into 3 of them, so they definitely exist. What am I missing?

The device I’m trying to upload to is a creality ender 3 Pro with the V1.1x board. It already has a bootloader burned to it, so it should be a recognizable device. What am I missing?

Okay then let’s check that. Are you on Windows? If yes, what are the list of COM ports shown in the device manager?


It’s showing USB-SERIAL CH340 (COM3) which goes away when I unplug the printer, so it’s definitely that

Alright then please go into PIO Home -> Devices, press Refresh and then Alt + PrntScreen to create a screenshot, then Ctrl+V that into here.

I’m not sure how, but it showed up. Now the issue is “Access is denied”


You don’t need to install the “Arduino” extension to use PlatformIO in VSCode. But it also shouldn’t cause an error… I hope.

Do you have any other serial monitor program open that could possibly use COM3?

1 Like

Well I suppose something must have been. I closed everything but VSCode and this browser and it suddenly worked. I guess I should’ve tried that earlier