Serial port gibberish characters

Hi all,
I’ve been trying to setup a serial port example with platformio and ESP32 thing from Sparkfun but I get gibberish characters. I checked the baud rate and updated the monitor setting in platformio ini but still the same result.
The port is correct and the baud rate shown in the monitor. I read somewhere while searching a lot that the crystal in ESP32 thing is different than the default 40MHz used from other boards so I found it is 26MHz and changed it in file: sdkconfig.esp32thing.

platformio.in file :

[env:esp32thing]
platform = espressif32
board = esp32thing
framework = espidf
upload_port = COM[5]
upload_speed = 115200
monitor_port = COM[5]
monitor_speed= 115200
monitor_filters = direct, esp32_exception_decoder
monitor_rts = 0
monitor_dtr = 0

Any ideas on what is wrong ?
Screenshot_1

That’s not the safest way to do it and might break things.Can you use the menuconfig task listed in the project tasks to find + change the crystal frequency properly?

In the beginning I tried to edit it myself cause I couldn’t find how to navigate through the menuconfig. I finally read somewhere that you use J and K keys to move up and down and finally changed it from there. So what you see are the menu changes.
I wish that menu was more user friendly. It’s hard to move around it needs a graphical environment.