Serial Monitor not working


#1

Hi, I am new to PlatformIO running on WIN7.

I complied and uploaded a sketch using Serial.println(“Hello World”) on an Aduino UNO board.
The serial monitor window does not display any output.
The serial monitor setup detects the correct comm port and the baud rate is also set correct.

Compiling and uploading the same sketch in the Arduino IDE shows the Arduino serial monitor working fine
The CoolTerm serial monitor also works perfect with this sketch.

What am I missing?
Thanks!


#2

Does CoolTerm work when you use PlatformIO for uploading?


#3

Yes, I upload the hex file to the UNO.
The test program has a LED blink and Serial.println routine. The LED blinks but the Serial Monitor window shows no output.
If I run CoolTerm I get the serial output on its window

Thanks


#4

Do you use the same baud rate and port?


#5

Yes same baud rate and port. Platformio detects the correct port


#6

Could you run in PlatformIO IDE Terminal:

pio device monitor --encoding hexlify
pio device monitor --filter debug

See other options for debug:


[solved] Enable just local echo in serial monitor
#7

PlatformIO / terminal / new terminal…opens new terminal window with blinking cursor but does not accept any text
(Can’t type in the terminal window)


#8
  1. Check that you use the latest Atom Text Editor: Menu: About
  2. Atom > Settings :gear: > Updates - do you have any updates ?

#9

I’ll join this discussion since I have the same problem, I’m on Linux though.

Your suggested commands show the expected output (counter going up, one in hex one showing the received chars).

No updates. Maybe a permission problem?


#10

Do you mean that it works with pio device monitor --encoding hexlify and doesn’t work with pio device monitor?


#11

No, from the command line it works for any case, at the moment I am using pio device monitor --baud 115200 and stop/start before/after programming to debug.

What doesn’t work is the serial monitor within the IDE (clicking on the little plug on the lower left)


#12

Success!
I have updated PlatfornIO with the latest software and the Serial Monitor and Terminal are both working perfectly
Thanks for all your support!


#13

For me this problem has now appeared.
Background is: I uninstalled VSCode as well as all directories and reinstalled Atom and PIO.
Everything is working well.
However when I try to use the serial monitor (Shift+CMD+M) it is black text (I think) on black background.
I have tried several themes. The effect is the same: Background can be green, text is still invisible. Only the cursor is visible. Using any external terminal works fine. Problem is the same on Terminal (Shift+CMD+T) Also the build terminal works fine (White text, Black background. Have only seen this since a fresh install yesterday, Home 0.9.5·Core 3.5.3b2. Have tried a few different Terminal Themes. Does not solve the problem.


#14

I am having the same problem with serial monitor / just see a blinking cursos

  • All sw up-2-date
  • Tried different themes
  • Serial port works with other monitors
  • Serial monitor ports and baudrate is properly detected

Also the terminal does not work with my platformio (blinking cursos).
Hope somebody has some suggestion?

Thanks


#15

Does it work when you invoke miniterm.py directly? (i.e. try miniterm.py <your device file> <your baud rate>)


#16

This is a problem with Atom. Please switch to https://platformio.org/get-started/ide?install=vscode


#17

Your solution is to switch to a Microsoft product? That’s not really a solution is it?


#18

Could you provide a simple code to reproduce this issue?


#19

Its a regression from an update you pushed ~ 25 days ago.


#20

Could you provide more details? Which version does work for you?