Science Journal on Arduino101. It compiles and uploads but it does not work

Hello everyone.
Im trying to make an Arduino101 board links with Science Journal app on my Android.
Im on a Windows 10 machine.

With some help here and elsewhere I made the needed Firmware to compile and upload ( GitHub - google/science-journal-arduino: Science Journal Arduino Firmware).

Now Im stuck there.
It doesn’t work with Science Journal app neither with other apps that should recognize an active bluetooth device around (like the one I tried to use called BLE scanner).

Conversely though, If I upload a BLE sketch on Arduino101 called Scan.ino it recognizes devices around.

So, it seems it is able to receive a signal but not to transmit one so to say.

Thanks to who tried to help me here: Dfu-util location missing trying to upload Science Journal firmware on Arduino101 - PlatformIO IDE - PlatformIO Community

and on another forum ( Problem with dfu-util trying to upload on Arduino 101 - Arduino Education Kits / Arduino Science Journal & Arduino Science Kit - Arduino Forum)

and I hope I could find some more help to end this endeavor.