Run Example PlatformIO on VScode failure

Today I multiple try to run an example of PlatformIO on VSCode but get an error:" Could not found Package with ‘framework-siwisdk @ 5.0.5’ …"

I used the Installation guide on the git addressed: GitHub - waybyte/logicromsdk: Software framework for 4G LTE Cat.1 SoC (RDA8910), 2G SoC (MT2621/MT2503/RDA8955) and NB-IoT SoC (MT2625).
What does this mean and how do I fix it?
VSCode : v1.48.2
PlatformIO: v1.10.2

In platformio.ini, in lib_deps, do you have spaces around @5.0.5 by any chance? It could be that. (I’ve never used spaces and when PlatformIO put stuff in there for me, neither has it.)

Also, that format means “always use version 5.0.5” - I assume that is what you want?

If you installed manually, did you follow these instructions? logicromsdk/quick_start.rst at master · waybyte/logicromsdk · GitHub.


Hi, thank you for your reply.
The platformio.ini file does not contain any @5.0.5 value to check a space around it.
The version used is set by default. Can I run the example without error with another version?
when I use the instruction, I still get the previous error.

Error is:

‘platformio.ini’ file includes:

; PlatformIO Project Configuration File
; Build options: build flags, source filter
; Upload options: custom upload port, speed and extra flags
; Library options: dependencies, extra library storages
; Advanced options: extra scripting
; Please visit documentation for the other options and examples
; Redirecting...

default_envs = s20gsm

; Common env setup
platform = siwigsm
board = s20gsm
framework = siwisdk
monitor_speed = 115200

; Release env

; Debug env
build_type = debug
debug_build_flags = -Os -g2

Cannot find your platform. Maybe GitHub - waybyte/platform-logicrom: Development Platform for 4G LTE (RDA8910), GSM (MT2503/MT6261/RDA8955) & NBIoT (MT2625) Chipsets. will help?