RF24 library failed compiling

I tried following the example shown here - PlatformIO Registry

I get the following error in terminal view for platformio build (last few lines)

I have added the lib_deps = 433 as suggested in the link above.

#include <RF24/RF24.h> ^ compilation terminated. scons: *** [.pioenvs/due/RF24_ID433/examples_linux/interrupts/gettingstarted_call_response_int.o] Error 1 ========================= [ ERROR ] Took 2.52 seconds =========================

Please let me know if I am doing something wrong.



You use PlatformIO 3.0 but lib_deps option is implemented in PlatformIO 3.0 (is not released yet). You have 2 options:

  1. Switch to PlatformIO 3.0 development Redirecting...
  2. Use PlatformIO 2.0 but replace lib_deps = 433 with lib_install = 433

Hi Ivankravets,
Thank you for your immediate response. I am getting the same error with lib_install=433. Somehow, the examples_linux and utility folder are getting copied into .pioenvs/due/ .cpp . These examples are meant for R-Pi and other devices. I think that is why it is failing. Is there any option to build the source code without building/compiling the examples.

I am using PlatformIO as an Atom package (on About page in Atom it displays IDE = 1.4.0 | Clang = 2.11.2.



@mcprakash you need Redirecting...

Hi Ivankravets
Thanks. It works now. You can close this issue.