Resolved - Serial Port not not found by platformio- it was a build issue with platformio

I seem to have the opposite problem others have had. I am new to and I am trying to build a ESP32s3 tasmota image. I am not new to development (started in the70s literally…), so my question is probably a bit fundamental. I have a working design of a ESP32s3 board that I have imaged from arduino over a normal serial link in windows (COM3), so I know the board is just fine. I run chip_id and the tool talks to the board and gets the chip id perfectly -

PS F:\development\ESP32 Dev\projects\Tasmota-development> chip_id v4.5.1
Found 2 serial ports
Serial port COM3
Detecting chip type… ESP32-S3
Chip is ESP32-S3 (revision v0.1)
Features: WiFi, BLE
Crystal is 40MHz
MAC: f4:12:fa:ca:91:50
Uploading stub…
Running stub…
Stub running…
Warning: ESP32-S3 has no Chip ID. Reading MAC instead.
MAC: f4:12:fa:ca:91:50
Hard resetting via RTS pin…

I have run BLE test code from Arduino, uploaded, and run the code successfully. I just dislike the arduino build environment and wanted to use something more appropriate especially for something as complex as tasmota

I have set the ESP-IDF and upload/monitor port to com3 at the bottom buttons. I have changed platform_override.ini to specific com3 as the upload port. I build but I get the following line at the end before it tells me it has failed.

*** Serial port used for erasing\flashing the ESP32’ not found, needed by target `.pio\build\tasmota32s3\partitions.bin’.

I either have missed something I needed to set or the multiple places where settings seem to be are being ignored.

I had been looking at ways to have a verbose build text that at least would tell what commands are even being run that failed, so I can figure out what caused the serial port message.

Any assistance would be appreciated. Thank you. Steve

This more sounds like you have accidentally uncommented this comment

and now PlatformIO has interpreted that as a file needed for building / uploading the firmware. This section is supposed to look like

; *** Serial port used for erasing/flashing the ESP32
upload_port             = COM3
monitor_port            = COM3

I had already copied the sample and modified platformio_override.ini by uncommenting the esp32 section. The upload_port and monitor_port are uncommented. I even tried commenting the ports back out and no change.

In looking at this further, I believe the partition CSV file is incorrect. I am looking at the partition doc to attempt to figure out how to fix it. Thank you for taking the time to help.

Another run… cleared out my modified version of the tasmota build and started over. The “error” I saw before was just during a build task and not even the upload task (I am learning).
I setup platformio_override.ini and uncommented out the ESP32 section.
I changed the com ports in it to com3 for my hardware.
I selected the qio_opi.json file for my processor
I changed the memory size to 8MB from 4MB

here is the platformio_override snippet of that area

board = esp32s3-qio_opi.json
board_build.f_cpu = 240000000L
board_build.f_flash = 80000000L
board_build.flash_mode = qio
board_build.flash_size = 8MB
board_upload.maximum_size = 8388608
board_upload.arduino.flash_extra_images =
board_build.partitions = partitions/esp32_partition_app2944k_fs2M.csv
; *** Serial port used for erasing/flashing the ESP32
upload_port = COM3
monitor_port = COM3

haven’t check if the code runs yet, but it builds properly and downloads to the ESP32s3 in the UPLOAD task.