[Resolved] Can't find platformio command, keeps trying to install?

Every time I open Atom it is trying to install but it fails and I get the following error:

Can not find platformio command. Please install it using pip install platformio or enable built-in PlatformIO tool in Menu: PlatformIO > Settings > platformio-ide package.
Traceback (most recent call last):
File “/usr/local/bin/platformio”, line 7, in
from platformio.main import main
File “/Library/Python/2.7/site-packages/platformio/main.py”, line 21, in
import click
ImportError: No module named click

any ideas?
thank you

Try this (solved for me):

edit: it still is stuck in an endless install loop. installs fine though.

that did it, thank you!

I’m having a similar problem. Every time I launch Atom, it opens up installing the PlatformIO IDE package. I’ve tried uninstalling and then reinstalling the IDE in an attempt to get it out of this bad state, but it didn’t help. Each time it installs okay, but I have to wait for it to finish before I can do anything.

In my case pio command is working fine. Path variables all good.

I also ran the python script @Sufomba posted, but no joy.

Any suggestions?

Try to remove ~/.atom folder from user’s home directory and restart IDE.

I’m having a similar issue. I deleted the /.atom directory, reinstalled platformio-ide package and ran pip install -U platformio on the command line. The good news is I don’t get any errors. The bad news is that every time I restart Atom the “PlatformIO IDE:Installing” dialog pops up.

This bug is related to Windows OS. We are working on the quick solution and are going to release PlatformIO 1.2.1 with hot fix.

Sorry for inconveniences.

I’m on Mac, so I’m not sure if it’s just related to Windows. But the new update solved it for me. Thank you.

Yes, we have just released PlatformIO IDE 1.2.1 with hot fix for Windows OS. Please upgrade.

Thanks for the quick response @ivankravets . The upgrade resolved the issue on WIndows (I was not experiencing this problem on my Mac).

I installed Atom and PlatformIO as an alternative to the Arduino IDE. I really like this new solution - including integration with GitHub and the command line. The editor itself is great. I will be using this IDE for more than Arduino. Now that I have the IDE working on Mac and Windows - and because of your help and quick response - I will be making a donation today. Thanks for all your hard work on PIO!

1 Like

Thank you too! Happy Coding with PlatformIO! :blush:

I got version 1.2.2 and the issue is NOT solved. every time I fire up atom it keeps reinstalling platformio ide!!

Please tell us how to fix this!

What is your OS? Do you see any errors?

OS: windows 10, fresh install and latest version of everything on atom.io side, also tried the dev versions without luck, really annoying