PlatformIO Community

Register Library fails - Method Not Allowed

So i tried to register a small library to the registry, but I always get

 Error: [API] Method Not Allowed 

as a response. I guess this refers to the HTTP Response code 405 (?) but I have no idea what causes this.

The library is on GitHub (https://github.com/mbed-libraries/mbed-button.

I’m using PlatformIO, version 4.4.0a4.
I used the following command to register the library pio lib register

 pio lib register "https://raw.githubusercontent.com/mbed-libraries/mbed-button/master/library.json" 

I also tried without the quotation marks and with http instead of https with the same result.

I tried the same command with a library of somebody else that is already registered and the error does not occur, so i guess it’s not a problem with my client but with my library.

I can’t figure out what could be wrong so I would be grateful for some help.

Hm, I don’t see anything inherently wrong with the library manifest; It maybe related to currently undergoing changes in backend and frontend for the new PlatformIO library registry (Library version/revision identification issue) so that outages are temporarily experienced before the new release drops? @ivankravets

Sorry for the issue. We will fix that incorrect message soon. You can’t submit manifest link anymore. You need to publish a library under your account. New CLI is available in PIO Core 4.4 which is still in development. Please do the next:

pio upgrade --dev
pio package publish /path/to/local/source/code/of/library

Does it work?

1 Like

Yes, that worked.
Thank you.

2 Likes