Raspberry Pi Pico (RP2040) Will not upload when using my windows pc (all other boards work)

So for some context I have been able to upload a simple blink program to the board from my mac as a test to see if the board was the problem. The upload worked without a hitch which leads me to believe it has to do with the environment and not PIO or the board. Has anyone else experienced this error. There is no obvious fault here in the output just that it always fails right after compiling. If I drag the resulting uf2 file into the pico it works as expected. Not sure how I should go about this…
System Specs:
Windows 11
Newest Version of VSCode (new computer everything is completely up to date)
Raspberry Pi Pico
Here is the output:

Processing pico (platform: raspberrypi; board: pico; framework: arduino)
Verbose mode can be enabled via `-v, --verbose` option
CONFIGURATION: https://docs.platformio.org/page/boards/raspberrypi/pico.html
PLATFORM: Raspberry Pi RP2040 (1.7.0) > Raspberry Pi Pico
HARDWARE: RP2040 133MHz, 264KB RAM, 2MB Flash
DEBUG: Current (cmsis-dap) External (cmsis-dap, jlink, raspberrypi-swd)
 - framework-arduino-mbed @ 3.1.1 
 - tool-openocd-raspberrypi @ 2.1100.0 (11.0) 
 - tool-rp2040tools @ 1.0.2 
 - toolchain-gccarmnoneeabi @ 1.90201.191206 (9.2.1)
LDF: Library Dependency Finder -> https://bit.ly/configure-pio-ldf
LDF Modes: Finder ~ chain, Compatibility ~ soft
Found 37 compatible libraries
Scanning dependencies...
No dependencies
Building in release mode
Checking size .pio\build\pico\firmware.elf
Advanced Memory Usage is available via "PlatformIO Home > Project Inspect"
RAM:   [==        ]  15.1% (used 40696 bytes from 270336 bytes)
Flash: [          ]   0.2% (used 4034 bytes from 2097152 bytes)
Configuring upload protocol...
AVAILABLE: cmsis-dap, jlink, picotool, raspberrypi-swd
CURRENT: upload_protocol = picotool
Looking for upload port...
Auto-detected: COM3
Forcing reset using 1200bps open/close on port COM3
Uploading .pio\build\pico\firmware.elf
rp2040load 1.0.1 - compiled with go1.15.8
*** [upload] Error 1
====================================================== [FAILED] Took 15.23 seconds ======================================================

 *  The terminal process "C:\Users\bickf\.platformio\penv\Scripts\platformio.exe 'run', '--target', 'upload'" terminated with exit code: 1. 

As discussed in https://github.com/platformio/platform-raspberrypi/issues/2#issuecomment-828586398, on Windows you are required to use https://zadig.akeo.ie/ to load the right driver for when the Pico is in bootloader mode.

I have downloaded the drivers and still no luck even with full reboot of system. The device now doesn’t show up in my device manager at all for any sort of debugging

Please plug in the Pico in bootloader mode (hold down BOOTSEL and keep it pressed while inserting the USB cable) and show a screenshot of devices in Zadig with Options → List all Devices turned on.



Update I was able to pull it back up and re-do the drivers but it still doesn’t pop up on any communication port. Everything still works fine for all arduinos as well