PlatformIO Community

Qt creator suitable kit

Hi,
I am trying to integrate PlatformIO with qt creator on macos catalina, but seem to struggle a little… I can’t figure out how to configure the project to use a kit: No suitable kits found.

what I have done

  1. install platformio & qt-creator: (brew install platformio && brew cask install qt-creator)
  2. create project and initialize: platformio init --board esp12e --ide qtcreator
  3. open project file in qt creator…

In the Projects mode, all default desktop kits are grayed out, saying “you cannot use this kit, because it does not fulfill the project’s prerequisites.”
I also tried to create a manual kit with the platformio compilers (c++ and gcc in ~/.platformio/packages/toolchain-xtensa/xtensa-lx106-elf/bin/), but that also is not fulfilling the prerequisits…

In terminal, I can use the several platformio commands to build and upload the sketch with no trouble. Any ideas how to make it run as smoothly in qt creator? Thanks a lot in advance :slight_smile:

Have you gone exactly through the setup steps demanded by the documentation? (https://docs.platformio.org/en/latest/integration/ide/qtcreator.html)

Were there any errors when following these?

yes, I followed these instructions, the issue is at step 2.

  1. Import project via File > Open File or Project and select platformio.pro from the folder where is located “platformio.ini” (Project Configuration File)
  2. Select default desktop kit […] <- not possible

On which OS and QTCreator version are you trying this, for reproduction?

macOS Catalina (10.15.4 (19E287))
Qt Creator 4.11.2

I’ll try and reproduce on Win10 and Linux, as I have no Mac.

I guess the manual integration way (https://docs.platformio.org/en/latest/integration/ide/qtcreator.html#manual-integration) is broken too?

yes, that does not work either, since the ‘empty qt project’ does not exist to start with…
when I select e.g. ‘other project -> empty qmake project’, I have the same issue. might be it’s not a platformio issue at all ¯_(ツ)_/¯

it is probably related to me installing qt-creator with homebrew, which is mac specific. I have narrowed it down to qt-creator not finding the qt version, that is also installed via brew.

using the installer from their webpage, it suggests to download a ~20GB package of qt stuff. my guess is that it will have its prerequisites fulfilled then.

I have switched to Atom instead, there everything works fine now. this thread can be closed.

thank you very much for your efforts, @maxgerhardt!

We recommend using VSCode instead of Atom.

1 Like

I had the same problem and fixed it by adding the following lines to the platformio.pro file:

CONFIG += console
CONFIG -= app_bundle
CONFIG -= qt

The platformio init --ide qtcreator command should be doing this to avoid the need for the user to install the Qt library.

1 Like

I’m sure https://github.com/platformio/platformio-core/issues/3046 is a good place to put this hint there for the developers.

I tried this, but Qt Creator still says “no suitable kits found”.