Problems with RTClib by NeiroN version 1.6.2

Hello, I’m new here, so I already apologize for any slips I may make…
I’m trying to import a project developed in Arduino IDE 2.0.3 but I’m encountering a problem with the RTClib library by NeiroN (GitHub - NeiroNx/RTCLib: A library that makes interfacing DS1302, DS1307, DS3231, PCF8583, PCF8563, RTC_Millis Real Time Clock modules easy.).
In Arduino IDE the version of the library I’m using is 1.6.2 (the latest available) but in PlatformIO (Libraries Registry) only version 1.6.0 is found, and unfortunately it doesn’t work in my project (it has compilation errors).
All other project libraries and dependencies work perfectly. I did a test by importing the project and selecting “Use libraries installed by Arduino IDE”, which passed during compilation, but I would like to eliminate this dependency in case I change the code on equipment that does not have Arduino IDE installed.
Is there any way to install version 1.6.2 of this library directly on PlatformIO, either by syncing via GIT or otherwise?
Thanks in advance for any help.

Just point to the direct zip download for the stable 1.6.2 tag.

lib_deps =

in the platformio.ini, possibly along your other needded libraries.

CC @ivankravets do you mind updating PlatformIO Registry to 1.6.2?

1 Like

Added PR

1 Like

Sorry, didn’t know that keywords field is preventing PlatformIO from getting updates. I have just released v1.6.3 which, hopefully will fix this. Thanks!

I don’t even have words to thank you, thank you very much.

I’m not sure if it worked, the IDE still doesn’t show version 1.6.3, only versions 1.5.9 and 1.6.0.