PlatformIO Community

Problems using Littlefs and esp32

Hey, good morning.

Cloned it again and this time it seems to be working.

Now I’m getting:

image

This is the output when I try to create the image:

image

Okay that looks better but now you must compile the mklittlefs first. Do a make dist again that folder, then search for the produced binary, check that it runs, and overwrite your old mklittefs.

Ok, I copied the created file. But the output still the same.

sh: mklittlefs: command not found

What does it say now when you run the file with ./mklittlefs?

Here’s the output:

image

Looks good – and the new mklittlefs file is now in the same place as the old one?

Have you tried modifying the script to include the ./ at the beginning?

env.Replace (MKSPIFFSTOOL = "./mklittefs")

you may also try and replace it with the absolute path. (pwd to find out the current working directory.)

1 Like

Now that almost worked!

image

Why am I still getting SPIFFS image?

My board_build on the .ini file equals littlefs

The output text “SPIFFS image…” is static and can’t be influenced with the script – it very likely just works now.

Thank you very much Max!

In case anybody else has this problem, my solution was to build mklittlefs from source, and then place it in /usr/local/bin

Good luck!